Keyboard blocks last taxon results

I can not get to ANIJS, and i am not able to scroll.
A bit comparable as i had with chaning my password
a few month a go, i was also not able to get there and the keyboard was preventing from accessing the app
https://www.inaturalist.org/observations/81898827

I don’t really understand the question. Could you explain the issue more?

There is a plant Anijs, but it is not visible and i can not scroll to it.
Why can i not scroll in this wind to get to plants which are lower and not visible.
Is it possible that the WordChecker can cause problems ?
3.1.1
IOS13.4.1

https://www.inaturalist.org/observations/81898827

I tried it again with “Meeuw” “gull”’ without photos and the last two “Meeuw” choices can not be reached. I think the spellingschecker (how did it show up somehow ? with version 3.1.1 ?) id causing the problem.

The last two options in the proposed list are, it seems, never accesible and can not be choosen.

Have you tried including the space before and the space after?

No, but what does it do ? Now with “SPACE” I do get the last “Placeholder” option which is a workaround and does deliver me the last -before unreachble- option i think. Never realised that i often never got this “Placeholder” option too.

One space in the end gives the same result

I cannot replicate your problem because I use the website rather than an app and because my language is English, but I’ve had similar problems where the list of possible taxa is too long to view.

Have you tried entering the Latin name? If you know it, that should narrow your options to a very specific list which will likely include the species you’re looking for. And that ought to work across all apps and languages.

3 Likes

It is only partly because it is too long to view, but the last two (if there are20, 200, 2000 choices) i can not choose.
I think it is solved if I could swith off language spellingschecker for iNaturalist. Any idea if that is possible ? I only know of this problem since, i think, i wanted to change my password. It took me 4 hours to change the password and to get in the website an in the app.
I do not think it is a language issue but a settings issue.
At least i do not think i had this problem in 2017-2020, I only remember it from corona times (2021?)
My language for iNaturalist is, i think, english.

I think the keyboard is blocking the last two options; on LG there is a button to put the keyboard down, but I don’t think iOS has that. Maybe swiping down on the keyboard would make it disappear?

1 Like

I think it is not the keyboard, i think iNaturalist is well aware of the keyboard, but the spellingschecker who showed up last 24months i think.
The solution would be to expell iNaturalist from the spellingchecker.
I changed the 2nd option from the Bottom and now i am able to reach “Anijs” “Anise” but not “placeholder”


“Anijs” is visible and selectable but no Suggestions from the Spellingchecker anymore

So you are right about the last option “Placeholder” which is still blocked.

The language in the screenshot in the initial post doesn’t look like English. Could that be another anomaly introduced when you changed your password?

I thought, but i am not sure, that the old page did not had problems. I think it is a combination with new page ( i thought there was no save button where a save button should be, activated settings on my iphone.
Actually i hade problems on both the website (english) as the iphone (NL) so if it woiuld have been the website i should not have probelems on the website.

But if you activate some options on the iPhone i think you will never ever be able to change the pw on the iNat app as some buttons just hide between others. i know that by typing the pssword the iphone also came with options which was very annoying.

Hmm, embarrassingly this is an old issue that seems to have slipped through the cracks, I’m sorry about that: https://github.com/inaturalist/INaturalistIOS/issues/426 I’ll see if we can get a bug fix included in the next update.

2 Likes

I thought i never had those problems in 2.8 or so, a version which i had for a very very long time but only uploade 1 photo which, after al, was to live with but nowadays i do not travel and do not upload much photos and do not have a huge photo library which takes a lot of scrool time every time.

A active person on forum did not had this problem which convinces me that it depends on the (active) settings in the iphone as she had, i thought, the same inat ios app version (3.1??)

Note: I just changed the title to more generally describe the issue for clarity.

3 Likes