Can only see scientific names in Seek

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website):
iOS most recent version

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) :

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Scientific name is displayed when scanning

Step 2: I go to settings and switch Seek’s Camera to Regular names (in Dutch: Gewone Namen)

Step 3: Camera still only displays Scientific Names

1 Like

Hi @saberbe, welcome to the iNaturalist Forum and sorry you’re experiencing this issue. I tried changing my phone language to Dutch and testing this out in Seek 2.12.14 (217) on iOS 14.7.1 (iPhone 11) but wasn’t able to replicate the issue.

Could you share a couple screenshots or examples of species that display only the scientific name on the camera view? I wonder if could be that they just don’t have a Dutch name entered into the system.


Hello and thank you for your reply.

I have the same settings as you do, but the scientific name is displayed for all cases.
For instance;

I do notice that whenever that’s the case, the name is in italic. When the app is still trying to work things out, a dutch classification is given, and then text is regular;

Thanks for sending screenshots! Looks like there isn’t a Dutch name set for those taxa on iNaturalist.

(except for that last one:

You can add a name in Dutch by going to the Taxonomy tab for any species/taxon, then clicking Add a name (Naam toevoegen) on the lower right.