Link not working in observation field

Platform Website
Browser, Chrome

https://www.inaturalist.org/observations?verifiable=any&place_id=any&field:New%20species%20reference%20and%20name=Otholobium%20(Psoralea)%20algoensis%20Eckl.%20Zeyh.

in a comment, when clicked, gets loaded without the last fullstop and therefore yields an empty set.
If you manually at the fullstop to the url bar it works.
adding two fullstops does not solve the problem: they both get stripped off.

(note too that in “field” the inclusion of ‘&’ as a character in the field renders the filter useless
so this would not work:
https://www.inaturalist.org/observations?verifiable=any&place_id=any&field:New%20species%20reference%20and%20name=Otholobium%20(Psoralea)%20algoensis%20Eckl.%20&%20Zeyh.
[I removed the ‘&’ to get the first example to work, so this value (~ Eckl. & Zeyh.) no longer exists]).

I would really like to be able to use wild characters too - like
&field:New%20species%20reference%20and%20name=Otholobium*
where * (or any other character) behaved as a wild card.

1 Like

URLs use some characters to mark parts of the URL, so if you include them in a parameter of the URL, the parameter gets divided into parts when the browser tries to parse the URL. The solution is to “URL encode” or “percent encode” the characters causing problems. The spaces in your examples have already been encoded (%20).

normal encoded
(space) %20
% %25
& %26
* %2A
= %3D

See https://en.wikipedia.org/wiki/Percent-encoding for more, and a web search will find many pages where you can paste your parameter and get it encoded automatically.

As for the trailing full-stop issue, that’s likely something the comment formatter does to prevent punctuation being appended to a URL by accident. You might be able to get the formatter to treat the last full-stop as part of the URL by encoding it. Normally full-stops don’t need to be encoded, so most automatic encoders won’t do this, but it’s legal:

normal encoded
. %2E
1 Like

Thanks, the %2E option works.

1 Like