Majority of my observations do not appear if I use the "Show Only My Observations" feature

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Android

App version number, if a mobile app issue (shown under Settings or About): 1.21.10

Browser, if a website issue (Firefox, Chrome, etc) :

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):



Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.): Whenever I try to view my observations in the “Explore” tab using the “Show Only My Observations” feature, 223 of my 270 observations are not visible, on the map or on the tab. All of my observations from Feb. 17 2021 onwards are present, but before that I’m just randomly missing observations. Not all of the observations before then are missing, but the vast majority are. I can’t find any pattern in which ones are missing and which ones aren’t. There isn’t a specific time period that they are missing from aside from before Feb. 17th 2021, there is no specific location they are missing from, it’s not caused by ID level, and there is no specific group or genus that is totally missing. It seems to be completely random. They only disappear if I use the “Show only my observations” feature, and if for example, I searched for observations of chanterelles from everyone, my observations will still appear, but if I search for observations of chanterelles from only me using that feature they do not appear. In the Observations leaderboard it still says I have all 270 observations. I’ve tried refreshing my observations, restarting the app, restarting my phone, and deleting and reinstalling the app, but nothing has worked. This isn’t an urgent issue, mostly just a minor annoyance, but it would be nice to have it fixed.

Step 1:

Step 2:

Step 3:

I wonder if you have this inadvertently filtered by New Brunswick. Are any of your missing observations from out of province?

I can confirm that the Android app doesn’t show all your observations to me either.

I think I know the cause of the problem, but I didn’t dig all the way to the very bottom.

This part I think I’ve solved – older observations which have been updated/indexed since Feb 17 do show up in the app. Ones that have not been updated/indexed recently do not. This means that you can force an observation to show up in the app by adding a comment/ID/fave/DQA vote/etc – I did this to 2 of them already, which is why it’s up to 49 now. (Note: I’m not suggesting you do that for all your observations.)

The cause of this seems to be that the Android app is calling the API with user_login instead of user_id. Compare the results of https://api.inaturalist.org/v1/observations?user_login=nbforager to https://api.inaturalist.org/v1/observations?user_id=nbforager.

image

image

Here’s where I sort of lost the trail – I’m not sure why user_login would only return recently updated observations.
At any rate, I suspect the solution is for the Android developer to switch to calling the API with user_id, but perhaps a fix to the API is also in order.

5 Likes

interesting. i wonder if nbforager changed login name around mid February?

here’s another thread that described something similar: https://forum.inaturalist.org/t/errors-discrepancies-in-getting-results-from-api-identifications-identifiers/19051 . if you look at the user mentioned in that thread, you can see a similar problem when doing a user id vs login observation search:
https://api.inaturalist.org/v1/observations?user_id=abigstone (1130 records)
https://api.inaturalist.org/v1/observations?user_login=abigstone (489 records)
https://api.inaturalist.org/v1/observations?user_login=aastone (641 records)

2 Likes

Excellent sleuthing @jwidness and @pisum. We’ll update the app to use user_id.

1 Like

No, all of my observations are within New Brunswick.

I was actually wondering if this happened because I changed my name, but I changed it well before Feb. 17th, so I don’t think this is the case.

what was your login name before?

noicechickenparmthe3rd. You can probably understand why I changed it.

2 Likes

noice!

here’s the breakdown:
https://api.inaturalist.org/v1/observations?user_id=nbforager (273 records)
https://api.inaturalist.org/v1/observations?user_login=nbforager (52 records)
https://api.inaturalist.org/v1/observations?user_login=noicechickenparmthe3rd (221 records)

221 + 52 = 273

so whatever the problem is, it’s related to the change in logins. if you’re saying you changed your login well before mid Feb, then maybe it’s possible that the app was still recording the records under the old login for some period of time (which would be another bug) or something like that…

do you remember exactly when you changed your login?

1 Like

I’m not sure exactly when, but I thought it was before February, however looking through the dates in the links you attached, the last observation under noicechickenparmthe3rd is on Feb. 15, and the first observation under nbforager is on Feb. 17, which coincides perfectly with the time period of my missing observations. I’m thinking I just have a bad memory and that is when I changed my name, because the dates line up perfectly.

1 Like