Maps gone for everyone today or just me?

Are the maps gone for everyone today, or just me? Just get little (or big) blue window where the map should go (web version). It looks like everything was reported to be in the middle of the ocean. Kinda making me seasick.

Can you please provide screenshot(s) of what you’re seeing, as well as URLs of the pages you’re on? I haven’t noticed any issues.

I had a problem with iNat being unresponsive about three hours ago, just showing the world map but never retrieving the observations I was searching for. After ten minutes or so, I stopped trying. When I came back an hour or two later, it worked again.

Any page I go to with a map, including observations and taxa pages, Map tab. Here are 3 examples. I use Firefox on an MacBook Pro. Just started yesterday. Could be just me, and if so, I can try some settings. I’ve never seen this before.

Pretty sure it’s a local problem since no one else has written in about it and everything looks fine here. I would try turning off extensions in your browser and, if you can see the maps then, turn on the extensions one by one to see which one blocks the maps.

It would also be helpful if you can open your browser’s console, load one of those pages, and then post a screenshot which includes the console. That will show any errors the browser is encountering. This page has instructions for how to view the console for the most common browsers:

1 Like

Okay, I’ll try some things. Thanks!

This is happening:

More info… looks like it’s running out of memory when it’s trying to load the map.

Okay, I did nothing (since that last screenshot) except go to another observation… and now it’s no longer running out of memory and it’s showing me the maps.

1 Like

I’m getting that a lot these days… the running out of memory thing… My iNat has been fine though… :)


That’s it! :stuck_out_tongue_winking_eye:


An out of memory error indicates a local browser issue (although it could be mitigated by some bad code). Had you kept your browser running for a long time? The simplest solution to me would appear to be restarting your browser.


Yep, and I did that and it still happened, but then it stopped. Go figure. Maybe it just had to catch up with the fact that the memory had been freed. I have much memory on my MacBook Pro, but keep loads of tabs and windows open (intentionally). It was likely just a situation I ran into and I did suspect that. It’s why I put it here instead of bug reports. It’s nice to know how to open the dev console now, though. :)

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.