Muted user's comments are shown as unread

When you mute the user you expect to not see their comments and topics, but both of these are still shown in an Unread category on forum, thus forcing me to go and expand them, without that they are forever left as unread, please make it so they just don’t show up at all. I know it’s likely an issue only discourse can fix, but wanted to notify you that it is pretty annoying and kills the whole point of a muting feature.


When you have read what you want to, click Dismiss for the unwanted residue.

1 Like

Where do I find this dismiss functionality? I’m probably looking straight at it, but for the life of me…

1 Like

Go to the user’s Profile and click on “Normal” under “Message” to access your other options:

When you click on your avatar to see your notifications, there are two buttons at the bottom. One of them is “dismiss.”

1 Like

OK I must have misunderstood the original question. I thought we’re talking about the “unread count” not going away if the most recent contribution was of a muted user:


(note, this is the first example of a “1” unread count I found - this is not a muted user for me).

So the notification on my profile picture doesn’t figure in here.

And I’m quite lost as to what issue this addresses:

When you click on your icon there’s a button “mark as reviewe”, but when I tried it, it didn’t work for any notifications.