My onscreen keyboard hides the text input panel in the Forum

#1

this isn’t anything i can’t work around, but it’s inconvenient at times:

most of the time that i’m using the web, i’m using a Surface Pro 3 running Edge on Windows 10 in “tablet mode”. usually i have no physical keyboard attached. so i’m just using the onscreen keyboard that pops up. normally when the onscreen keyboard pops up, it shifts everything above it up so that it’s not covering everything. but for whatever reason, the text input pane in the iNatForum doesn’t shift up enough. so i can’t effectively make longer posts without using a physical keyboard. (i could move the onscreen keyboard up, but it’s weird typing above the input box.) in the screenshot below, you’ll notice that in the text input pane, the preview section on the right shows 3 lines of text, but you can only see 2 lines on the input section to the left.

note: some other sites and apps have similar issues, but most of the apps and sites that i use don’t. so i’m hoping Discourse(?) can put itself into the category of sites that do it right.

1 Like

#2

This is probably something more suited for https://meta.discourse.org/ I did a quick search and didn’t see any immediately relevant topics but will do a bit more digging.

0 Likes

#3

i’ve been exploring this forum a bit more, and it looks like it’s possible to either expand the text input pane to fill the screen or to shift the forum from desktop mode to mobile mode, and these will allow me to type longer messages using the onscreen keyboard without text getting hidden (as much). these options don’t come without compromises, but they should work for 97% of what i’m doing on the Forum, i think.

1 Like

#4

well, i don’t know if anything changed in the forum, but this problem appears to be fixed now.

0 Likes

Screen elements sometimes shift position in the web version of the uploader (on a tablet PC)
#5

ok. i don’t know what’s different, this doesn’t seem to be fixed any more. and now there are other positioning quirks like this (which does not appear to happen in Chrome):

0 Likes