Screen elements sometimes shift position in the web version of the uploader (on a tablet PC)

#1

this might be a niche use case (affecting a low number of users), but i deal with it fairly regularly. so i thought i’d mention it. i’ve never encountered the problem when using a plain desktop machine, but mostly i use my Surface Pro on Win 10 in “tablet mode”, and i notice this problem fairly regularly. mostly i’m not using a mouse, though i do use a pen. sometimes i will attach a physical keyboard.

in general, my process for uploading is:

  1. pull up uploader page on Edge on the right side of my screen.
  2. on the left side of the screen, pull up Windows Explorer / Photos app. (i switch between the 2 apps on the left side of the screen.)
  3. drag photos i want from Windows Explorer to Uploader. (if i want to put multiple photos into the same observation, i’ll drag the photos i want in the order that i want them to appear, using the observation created for the first photo.)
  4. pull up the uploader in full screen (since i no longer need Windows Explorer)
  5. update locations, as needed
  6. update descriptions, add IDs, etc. as needed.
  7. submit

often, some time during #5, i start seeing the iNat header start to shift down ever so slightly over time. the more things i attempt to update, the more the header shifts down, like this:


in the screenshot above, notice that in the Editing pane on the left side of the screen, i have the description box highlighted, but the cursor appears above the box. the position of the cursor is where i have to click to select the description box. i also have to click at an offset position to access other controls on that pane, and also to access the Submit button in the header.

the observations themselves don’t seem to suffer from the shifting problem. but other windows that pop up are also shifted. so for example, here’s the location pop up that has been shifted:


as with the header and editing panes in the main upload screen, i’ll have to click with an offset to compensate for the shift. even though you can’t see where i’m hovering, it’s a little bit above the Acc(m) box, and you can see the tooltip box shows up way above the Acc(m) control. sometimes, the location pop up window shifts so much that the Cancel and Update Observations buttons go off screen.

i’ve been working around the problem by loading in smaller batches (fewer edits = less shifting). i suspect that, in conjunction with using a touch interface, #4 in my process (window resize) may have something to do with the problem. a few times, i’ve left the window in half-screen mode, and i did not notice this problem (but then i have only half the screen real estate to use). on my tablet, i also do a lot of pinch-zooming in and out, but i don’t think that’s an immediate trigger for the problem because i would do that even more if working only in half a screen.

1 Like

#2

Are you able to access the browser’s web console on your Surface? If so, it would be great to have a screenshot that includes the console.

However, with Edge switching to chromium (https://www.theverge.com/2019/3/23/18278465/microsoft-edge-chromium-browser-screenshots-features-hands-on) I wonder if this will be an issue much longer.

0 Likes

#3

ok. maybe the Chromium switch will fix it, but i’ll capture a web console screenshot next time i see issues.

interestingly, after i noticed that this (https://forum.inaturalist.org/t/my-onscreen-keyboard-hides-the-text-input-panel-in-the-forum/1265/4) was fixed in iNatForum, i’m starting to see the shifting of screen elements in iNatForum, too. it’s not as bad here, since i can just refresh and not lose anything, but i thought i’d point it out, just in case that helps trigger any lightbulbs. here’s a screenshot of that (with the latest notes from the Console):

0 Likes