Photo Load Error iCloud couldn't communicate with a helper app

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): iOS

App version number, if a mobile app issue (shown under Settings or About): 3.3.1, build 713 iOS 17.1.2…

Browser, if a website issue (Firefox, Chrome, etc) :

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: On my phone, I start an observation and I can upload one photo and move to next screen. If I try to upload more than one photo or I try to add another photo from the edit screen, it gives me the “Photo Load Error”

A few things that have changed right before I had this problem. 1) iOS update to 17.1.2 and 2) I switched my photos to HEIC format. …

But I don’t understand why iNat is pulling photos from iCloud, which I don’t really use. I see that it says that the sync for my iCloud photos is Off. Perhaps this is the issue. iNat only has “private access” to my photos (can’t change that setting - no option to do so).

I read a bunch of the Bug Reports in this forum and tried to fix: deleted app and reuploaded it for example. Didn’t help.

Thank you.

I use iCloud Photos, shoot in HEIC and am runing 17.1.2 and haven’t encountered this issue. Are you certain you’re not using iCloud Photos? If you go to the photo in your Photos app and swipe up, do you see this cloud icon?

How much storage space is left on your device? Usually this error occurs if your device doesn’t have enough storage to download a full-sized image from iCloud.

So I attach a screen shot of what the photo swipe up looks like on my phone.

Also, I’m using 116GB of 128. Not ideal but not the worst I’ve ever pushed it. I’ll delete photos tonight and see if it works better tomorrow.

Thanks

Sorry, wrong photo. Here’s the right one.

Yeah doesn’t seem like it would be a problem. Another potential issue is that you’re not able to connect to iCloud to fetch the full-sized photo (again, assuming it’s stored in iCloud).

I don’t have them going to iCloud. I sync them to Google photos manually …
I’m guessing that’s the problem but I don’t know why iNat wants to pull from iCloud.
They are all on my phone …

I also don’t understand why it will allow me to upload one photo but not more.
That’s particularly vexing.

Update: my issue went away after I restarted my phone. Sorry! But maybe it’s helpful to share what worked.

I just got this error today, too, though for me it won’t even allow me to add even one photo. Overall storage is at 225 of 256 GB, running 17.1.2, and I also have iCloud turned off from accessing my photos. Something internal in my settings relevant to iCloud must have changed today because I just set up an AirTag. But when I check the settings iCloud is still not connected to my photos. Did you ever resolve this?



2 Likes

Thank for the information! We haven’t figured out the cause of this yet. Sounds like maybe we need to maybe update the app to deal with a change in iCloud.

1 Like

I had this problem also. IOS is up to date, plenty of storage on my device, and photos are not in the cloud.
I restarted my device, and now it works. yay!

3 Likes