iOS app not allowing addition of photo

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): iOS iPhone 13 and iPad

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) :

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):
Attempts to Edit obs and add a new photo repeatedly fails on both iPhone and iPad. I have a screen recording from the iPhone to send to you, for what it’s worth.
Step 1: Select obs and click Edit

Step 2: Click + in Photos and choose Photo Library

Step 3:Click desired photo to add and click Add

The Details screen shows no photo added.

Click Done and recheck Obs, which shows no new photo. Am I missing something?

Working fine for me.

  • what sort of photo permission are oyu giving iNaturalist?

  • are you using iCloud backup for your photos?

Yes, it usually works okay for me, too. I do think I back up iCloud. Let me check Settings.

I also replied to your email at help@inat.

I tried rebooting the phone, but same thing.

I do use Larger Fonts, and some vision accessibility settings. Is it possible that is getting in the way?

Isn’t there a setting to empty a cache or buffer somewhere for inat?

Thank you for your responses!

I’m pretty sure that uninstalling then reinstalling the app will empty the cache, I don’t know if there are other ways to do it.

I doubt this is a cache issue. The cache should be cleared automatically in the background as long as you don’t completely close the app when you go to your device’s home screen. It should also be cleared when you log out of the app and log back in.

I doubt it would prevent the photo from being added to the observation, but it might prevent the app from displaying the photo addition.

Have you tried adding the photo, tapping Done, making sure the app syncs the observation, then checked the observation on our website to see if the observation has the new photo?

Well, it’s working normally now. I may have banged it into working right. Last night, I hit the show Selections icon really hard (I was a little frustrated). A large yellow ADD flashed ~in the middle of the screen~, which seemed novel. Then the screen blinked to where you can hit Done, and it worked that time.

And it’s still working. GOK

I was taking screen videos off and on over several attempts, so I may go through some of them and see i captured that activity. But I realize iNat doesn’t want to waste resources on the iOS versions

Great, I’ll close this report.