Rotate Right and Rotate Left Not Working on iNaturalist Website

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): MacOs Monterey 12.0.1 Chrome Browser

App version number, if a mobile app issue (shown under Settings or About):
Chrome Version 96.0.4664.55 (Official Build) (x86_64)

Browser, if a website issue (Firefox, Chrome, etc) :
Chrome Version 96.0.4664.55 (Official Build) (x86_64)

URLs (aka web addresses) of any relevant observations or pages:
https://www.inaturalist.org/photos/170161793

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):
The “Rotate Right” and Rotate Left" buttons on the photo information page don’t work anymore. I noticed that only the small photo gets rotated, the medium, large and original photos do not get rotated.

Step 1: Go to a photo info page like this one. https://www.inaturalist.org/photos/170161793?size=medium

Step 2: Click “Rotate Right”

Step 3: Click “View” The photo does not rotate. Even after refresh.

I’m on Firefox and rotation doesn’t work at all on image pages for my observations.

1 Like

I tried replicating and they rotate but only after a few hours.

Photos in the AWS Open Dataset are stored different from “all rights reserved” photos. For the latter, photos are cached by URL externally, and it will take at least 15 minutes to see any change in rotation due to caching. Photos that are licensed for reuse should get updated pretty much right away since there is no external cache, but your browser may cache them so you may need to reload the page to see any changes

2 Likes

All of mine are CC-BY but I’ll check again sometime.

Thanks. I checked a day later and the rotations are complete. I see the “small” and “original” versions of the photos rotate immediately. The “medium” and “large” take much longer. I heve set my rights to “No rights reserved.”

1 Like

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : AVG Secure Browser

URLs (aka web addresses) of any relevant observations or pages:
https://www.inaturalist.org/observations/10362139

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Click on i

Step 2: Click on Rotate button

Step 3: Waited more than 2 hours, still the same when viewing the observation.

On my Dashboard the picture is turned.
image

I added a photo to the Taxa page

In the Edit view, the photo is rotated, but dragging over, it just return to the origional position.

I noticed there was a topic on this issue, but it closed 15 hours ago. Definatelly not solved, sorry.

I used this function before and it used to effect shortly after done, if not immediately.

1 Like

It took more than 2 hours for me to see results. But changing the photo licensing may help.
https://forum.inaturalist.org/t/rotate-right-and-rotate-left-not-working-on-inaturalist-website/28143

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): website

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : chrome.

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

I had an observation where the photo was rotated to the right. To attempt to fix this, I pushed “Edit” for the observation, then for the photo I pushed “View original.” I then pushed “Rotate left.” Nothing happened, apparently. I pushed “Rotated left” again, and again apparently nothing happened. In the original edit window I then pushed “Save observation.” After looking at the observation, the photo seemed to still show no rotation. I then come back two hours later and look at the observation and now it appears both rotations did work so now the photo is too rotated. I now do the same thing I did previously, but “Rotate right.” Again nothing happens. I save the observation and reload it and still no rotation. I push the Shift Key and “Reload this page” icon and still the photo is not rotated.

I’ve rotated photos a lot in the past and it seemed to work perfectly fine and intuitively. Now it seems to be broken. I saw this issue 1-2 months back, but didn’t report it. I’m surprised no one has reported the issue in the mean time.