Website images not working

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Safari 14.1.2

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: When I open the iNaturalist website, no images show up and it says this server might be impersonating the actual server so it’s blocking the photos. This includes photos I try to upload from my computer as observations.

Step 2: Looking through the other topics on this matter, I tried resetting DNS and enabling/disabling Javascript, neither of which worked.

Step 3:

I think this may be a Safari issue. I use the same version of Safari (14.1.2) on my Mac and I get warning messages for certain websites (but not iNat!) because Safari thinks their certificates have expired, when in fact they haven’t. Someone else may be able to explain this better.

1 Like

I agree, I would try a different browser. Working as normal for me in Chrome.

1 Like