Unable to upload photos

I have been using iNaturalist regularly for the past couple of weeks and have uploaded several hundred photos without a problem. The past couple of days when I have attempted to upload some photos it just hangs loading metadata and does not display the photo and eventually displays an unable to load message. It’s not every photo, but more often than not it is failing and seems to be photo dependent.
All photos have been exported from Adobe Lightroom in exactly the same way often as a batch and some in the batch will load and other won’t. All the metadata looks OK, file size does not appear to be a factor and I can open up the photos in any other application I try.
It seems like a problem iNaturalist is now having with some photos. Any suggestions?

1 Like

If you try to upload the same photo again do you get the same error, or does it just randomly fail within a larger batch? You could try emailing an example photo that failed to help@inaturalist.org and they often help to try and troubleshoot the issue.

1 Like

If a photo won’t upload it doesn’t matter how often I try. I’ve tried changing the name, same result. Two photos of the same subject taken within a matter seconds, with exactly the same metadata except for the slight difference in observation time and both about the same size, I find that one uploads and the other doesn’t. It doesn’t seem to be a matter of size as sometimes the larger photo will upload and the smaller one doesn’t.
I’ve uploaded over 300 photos using the same process over the past couple of weeks without a problem but in the past couple of days it has been happening about 50% of the time.

1 Like

@Andill I’m sorry to hear that. It’s tough to diagnose an issue without a few more specific details, so it would be helpful if you could

  • send a screenshot of what you are seeing (instructions for how to do so are in the About the Bug Reports thread)

  • send one or two of the photos to help@inaturalist.org

  • let us know if you have had any changes to your browser or network

Not the same problem, but maybe related. I find that with Microsoft Edge things come to a complete standstill sometimes while uploading and all I can do in such instances is to restart the PC. (Even alt-cntrl-del does not work in such cases) It especially happens when clicking on location. With Google Chrome this never happens. . All with latest Windows10.

Yeah, unfortunately both Edge and Safari don’t comply to web standards like Chrome or Firefox do, so it’s more likely that errors will pop up when using them. It will be interesting to see what happens with Edge once it transitions to Chromium.

That’s great information to know Tony! I know iNat probably wouldn’t want to be seen as “endorsing” particular browsers, but a prominent mention of which browsers are “most compatible” with iNaturalist might help users to self-diagnose buggy behaviors like this one.

1 Like