Clicked action does not correspond to pointer location on upload page

Platform (Android, iOS, Website): Website, Win 10 and ChromeOS
Browser, if a website issue (Firefox, Chrome, etc) : Firefox 68.8.0esr (32-bit), it also happened in Chrome too (I can get details if needed)
URLs (aka web addresses) of any relevant observations or pages:

Description of problem : The mouse click is not hitting the correct part of the page. The first few rows are fine but further down the page the vertical reference gets offset. You’ll click somewhere and get the action from a link a few inches up the page. Zooming the page (Ctrl + or -) may temporarily fix the issue but it does not last and the last set of records near the bottom are impossible to get to.

Makes it challenging to merge photos, add locations, and add IDs. The tool bug is now making things very tedious.

1 Like

screenshots of your problem might help.
if you’re saying that changing zoom helps, it might help to say what kind of zoom settings you have.

what you’re describing sounds different, but i wonder if it’s similar to


I’m using Chrome browser on Windows 10 and all mouse clicks are registered exactly below the tip of the mouse pointer as it should be. I tried adding lots of photos (several rows) and it’s working fine everywhere - in text fields, map, drag and drop.

You have the issue on both operating systems - Windows 10 and Chrome OS?

1 Like

Well… it was. Seems to be intermittent. Won’t fail when I’m trying to document the fail. [Sigh] Feels like the system has detected when I want to get actual work done vs demonstrating an error.

I thought maybe my test images being loaded from the hard drive might be the reason it won’t fail. I usually work of SD card directly. So I tried again from SD card, still won’t fail. Dang. I wouldn’t have mentioned this if it was an infrequent occurrence. It’s been happening for the last couple months and is driving me nuts.

Simulated error: if I clicked at the blue location, the actions I get are as if the cursor was in the red area. Cursor click isn’t behaving oddly anywhere else except 2nd or 3rd rows of OBS being loaded. Top row of OBS never goes crazy. Highlighted area always works. Never had a browser do this before.

Not super high priority but any suggestions are welcome.


Oh, I may be dating myself with old tech (again)… in the old days you could go into System Preferences (or such like) and re-calibrate the mouse click if it got off point. But, if iNaturalist is the only place you have that happen, its probably not a system tuning thing.

1 Like

I just tested this on my mac in FF 77.0.1 and Chrome 83.0.4103.116 and couldn’t replicate. Both are zoomed to 110%, FWIW.

1 Like

Hi @tallastro - I’m checking in on some old bug reports. Are you still running into this issue?

I have not noticed it… I have changed how I interact with iNat a bit. I’m in favor of closing this ticket. Maybe it was just a bad combination of browser/OS/website versions that have all updated since.

Thanks for checking.