Screen is blank after pressing back button

For me, using a Windows laptop computer, iNaturalist doesn’t crash, but every time I push the back button, the screen comes up blank until I click to refresh the screen. This problem started a few days ago, right after the new version was rolled out to provide new formatting options for comments on the observation page.

1 Like

@tsn I split off your comment from the other topic since that one was referring to the Android app. Can you fill out the sections of the bug report listed at the bottom here? https://forum.inaturalist.org/t/about-the-bug-reports-category-please-read-before-posting/60

Platform : Website

App version number , if mobile app issue (shown under Settings): N/A

Browser , if a website issue: Firefox 78.0.1 (64 bit)

URLs (aka web addresses) of any relevant observations or pages : Any observation, anywhere on the iNaturalist web site

Description of problem:

  1. Look at any observation by any observer
  2. Click on the green arrow beside the observer’s name to go back to that same observer’s previous observation (which then appears as normal)
  3. Click on the black “Go back one page” arrow in the upper left corner of the Firefox screen to try to return to the original observation
  4. The page comes up blank until I click “Reload current page” in the upper left corner of the Firefox screen, and then the observation comes up as normal.
3 Likes

Thanks for that! I think Tony logged a similar issue via Github recently: https://github.com/inaturalist/inaturalist/issues/2731 (still unresolved there)

I get the same result in Chrome:

I get the same result in Safari 13.1.1 (latest) on macOS 10.15.5 (latest). I noticed this for the first time yesterday.

1 Like

I noticed this in Identify the past couple of days using the back-arrow on Safari 13.1.1 on macOS 10.15.5 as well. When I’m on one observation, then go get a google translation, then hit Safari’s back-arrow to go back to the same observation, the page is blank. If I hit the same arrow again, I get the page I want.

1 Like

seems resolved now: https://github.com/inaturalist/inaturalist/commit/374cf6bc4f9dd11f37afd3a65935ed99b5bca1a2.

1 Like

I agree with @pisum; the specific problem reported here (at least) appears fixed now (Safari 13.1.1 on macOS 10.15.5).

1 Like

@paloma, can you test your steps involving google translation now? I wasn’t sure exactly what steps “go get a google translation” involved in your case. The originally reported problem seems fixed, but it’s possible that your case is different.

1 Like

I have seen similar blank screens upon hitting the back key on an iPhone and iPad, Safari (up-to-date, I believe).

have you seen them since last night?

1 Like

No, I just tried on the iPhone and did not see such today.

2 Likes

It’s fixed for me as well. I had no problem yesterday. Thank you.

3 Likes