Seek App Shows a Black Screen While Trying to Share to iNaturalist

Hello, just like the title suggested. I am attending a class which requires me to post around 150 species onto iNaturalist through the Seek app. However, I’ve ran into this trouble even though I wanted to start identifying the species I found ASAP. I’ve also tried deleting and reloading the app multiple times, but I’ve experienced the same problem. Any help is appreciated. It is also my first time with this software, so I am still not familiar with it. I’ve also ask my classmates and professor but their Seek app works just fine so I’m not sure what to do.

Platform (Android, iOS, Website): IOS (16.6 up to date)

App version number, if a mobile app issue (shown under Settings or About): 2.15.0 (310)

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: I take a picture of a species or upload a picture.

Step 2: Seek was able to identify the species.

Step 3: Tap “POST TO INATURALIST” on the page that says “We believe this is a member of …”

Step 4: It shows a black screen where I couldn’t go back or do anything in the app

1 Like

I don’t think this is the cause for your particular bug, but some iOS users are having difficulty posting to iNat if their phone’s time zone is set manually. Is your phone’s time zone set automaticallly or manually?

Thank you for your reply! My phone’s time zone is set manually, and the app worked once I changed to automatically. Thank you so much!

1 Like

Thanks! I can replicate this in some cases, but only if I import photos taken in a different time zone from what my phone is set to manually. If I take a photo with Seek and my phone is manually set to my current time zone, I can upload the photo. Is that your experience? Any details would be helpful.

Same thing happens to me. Both photo and app are in the same time zone. Time zone is set to “auto” on iPhone. What an unstable app.

Bogus solution!