Species complexes and subgenera indistinguishable from species and genera on mobile app

Species complexes are indistinguishable from species on the iPhone mobile app (ver. 3.1.1. build 626) - they are displayed in the same way. And subgenera are displayed the same as genera. Can someone check if it’s the same on the Android app? Here’re screenshots of the iOS app displaying an observation page and a taxon page:


On the observation page at the website these taxa are correctly prefixed with the words “Complex” and “Subgenus” respectively:
https://www.inaturalist.org/observations/73496922
Where you can see that my ID is actually a species complex and nabu-nvp’s ID is a subgenus. And - judging by his comment - he did not see my ID as a species complex. Which illustrates the miscommunication that can occur with this ambiguity. Maybe he is using the app or the ambiguity is present in some of the web interfaces, too?

On a related note - I think the best way to display a subgenus is in the form “Bombus (Bombus)” rather than “Subgenus Bombus” since the first is more informative (and nearly the same length). This was suggested as a feature request here:
https://forum.inaturalist.org/t/display-genus-along-with-subgenus-section-etc/14107

There’s another suggestion for the display of species complexes here:
https://forum.inaturalist.org/t/adjust-how-species-complexes-are-displayed/12777

This was mostly fixed, but there are still a few places where they need to be distinguished. Closing to focus at existing discussion: https://forum.inaturalist.org/t/subgenus-section-subsection-complex-not-distinguished-from-genus-on-mobile/8304