Species page on Open Space page doesn't load

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Windows 10 Home; Version 98.0.4758.102 (Official Build) (64-bit)

opening tab : Species

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Navigate to url for Hastings Sand Coulee, SNA, MN US Open Space page - entry/opening tab (by default) is ‘Species’

Step 2: page is perpetually at ‘Loading’. I have let it run up to 20 minutes and reloaded the page but it never loads.

Step 3: navigate to the other three tabs on this page: Observations, People, About …

Step 4: those all load normally after a moment’s hesitation (nothing I would normally notice but I’ll report in the interest of being thorough).

I have accessed quite a few of these Open Space pages over the last year and this is the first time I’ve had this happen.

1 Like

That page loads perfectly after a couple seconds hesitation for me today. Are you still having the issue? Might be a temporary server overload issue.

I had this several times yesterday as well.
No issues if one uses the place as a filter instead.

I tried it just this moment and it loaded immediately. For what it’s worth, I tried it last night and it still hung at ‘loading’.

I just thought it was interesting that the other tabs loaded but not that one and, on the off chance it meant something was ‘broken’, I thought I’d report it.

1 Like

Yeah, loading fine for me now as well. If people find any more examples, please add them to this report.