Taxonomic view for projects?

Is there a view, filter or setting for listing the observations of a project in a taxonomic view (as seen on https://www.inaturalist.org/lifelists/stekkelpak?view=tree&details_view=observations&tree_mode=full_taxonomy)?

Take a look at these previous posts:

I think I found the/a workaround of sorts:

Replace the 1726 with the number of whatever project you’re interested in (1726 is ID of a project I run in SE Asia).

This seems to give a taxonomic view, but it appears to be incomplete. It should return 2026 taxa, but only returns 210. Maybe there is a limit placed on the returns?

And doesn’t have the same extra features as the lifelist view does (eg, no sidebar with images and such)

2 Likes

So it needs both project_id=1726 and projects=1726? Why the redundancy?

Doing some experimentation, I found that only projects= is necessary, the projects_id= field is unneeded.

If you don’t include the initial project_id=, when you go to look at observations of a specific species you get sent to global observations rather than observations just within the project.

That’s what it’s for. I have no idea why that’s the case, but if you leave it out it makes a difference for that portion. Makes no difference at the taxa level view though.

If you leave out the projects= portion, then you get an error reading and a page suggesting different ways to format the query.

I tried this query with my own project and got inconsistent results.

Using https://www.inaturalist.org/observations/taxa?projects=84529 produced 0 taxa observed. Clearly incorrect

Using https://www.inaturalist.org/observations/taxa?taxon_id=47903&place_id=6783&quality_grade=needs_id,research, which simulates the project criteria, produced 243 taxa observed. Possibly correct depending which taxa levels are counted.

Mine seems to work https://www.inaturalist.org/observations/taxa?project_id=79239&projects=79239 It came up with 813 taxa. I don’t know if that is correct but it seems around the ballpark. I have 694 species plus several taxa that I couldn’t get down to species

Not my project, but one I curate https://www.inaturalist.org/observations/taxa?project_id=10099&projects=10099 This looks good too. There are 1353 species and link comes up with 1666 taxa.

I wonder if that’s because yours is a taxon limited project and a place project rather than a universal collection project in a place.

Either way, I don’t understand why some folks are getting high numbers of returns while I’m getting roughly 1/10th of the returns I should be getting.

Clearly there is something weird going on under the hood.

In addition to my previous comment I also found that the “Download CSV” link doesn’t work - it produces a 404 error, resource not found. Certainly looks like something needs fixing.