Thumbnails in identify taking a long time to open to observation

Platform: Website

Browser: Safari

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem:

Step 1: In iNaturalist identify using iPad, with 2 standing filters

Step 2: On page of thumbnails, after I tap on thumbnail to get to the observation

Step 3: It takes a long time, sometimes more than 12 seconds for the observation to appear. If/when it finally appears, if I tap on the thumbnail in the obs, it takes a long time, sometimes more than 12 seconds to get to full size.

Step 4: Normally, sometimes on my iPad my tap doesn’t register, this can be solved by re-tapping. Perhaps because of my impatient re-tapping, when the picture finally appears, it is an enlarged fragment of the photo.

Step 5: frustrated with all this I hit the x button, the window does not go away.

Step 6: This has been going on for over 24 hours, every time of the multiple times I have tried to identify on iNat, and on every of numerous different obs I have tried to access. Things that I have tried that have not solved the problem: 1) closed all open windows including iNat 2) logging out of iNat and signing back in 3) Turning off iPad completely and turning it back on. 4) checking wi-fi speed: it is no worse than usual. 5) clearing then re-setting filters. When I tried to access Identify on the website on my iPhone even the page of thumbnails took a long time to fill in, and tapping on yet a different observation resulted in nothing happening for so long that my screen went blank before the obs appeared. I have had no problems with looking at my notifications or working on obs in the notifications, nor have I had problems with the speed of functioning of any non-iNat pages on either device.

I am computer illiterate, so any instructions for me will have to be in extremely basic terms.

The Identify page does seem to be slower than most other websites I use, but 12 seconds to load sounds pretty extreme - and frustrating.

I fired up an old iPad try to replicate this, but wasn’t able to (iPad 4 running iOS 10). When I tap on one of the photos in the Identify thumbnails, the Identify “modal”, that overlay on the screen with an X in the top right corner, appears within a second or two and the photo loads right away. This is on pretty speedy home wifi (240 Mbps download speeds per


Any chance you can share a URL or screenshots just to confirm we’re talking about the same place? Someone with more familiarity with Apple products might be able to troubleshoot further.

1 Like

this is hopefully a screenshot of the page open on my iPhone 12 Pro. I had tapped the leftmost thumbnail ( the grass seed head) and 5 seconds later this is what it still liked like. I cannot figure out how to take a screenshot on my years old iPad Pro running on iOS 14.4 even after clicking the link provided by iNat and viewing the available video
Another thing that didn’t work: accessing the identity page from iNat rather than from the identity page I have bookmarked.
On my several years old iMac desktop the speed of opening is fine. My home WiFi has 12 Mbps on a good day, including today
Thanks for trying to help

Don’t know what happened. The photo of the mussel shell is not a screenshot, though what it is below it is a screenshot.

I don’t see any loading time issues on my iPad Mini 5 running iOS 14.4. But do keep in mind that is not really designed for use with mobile devices so it often takes multiple taps to accomplish something. For example, tapping once on the common cicada observation makes the “Mark as Reviewed” option appear on my device:

I have to tap on it again to get it to pop up in the Identify modal:

If possible, can you make a screen recording of this behavior and email it to Sometimes video can really provide some insights into issues like this. Here are instructions for how to record your screen:

Yeaaaah. INat Identify is working for me again on my beloved iPad ! Not as fast as previously, but workable. What a relief! I was going thru serious withdrawals. Thanks for the wonderful learning experience about electronic devices and other computery stuff

1 Like

@smschnerremd, I’m merging your other topic here. Feel free to reach out to a forum moderator if a topic ever needs to be reopened.

I tried now, and it loads after 3-4 secs on my iPad, pretty much the same as website when you have no filters (all observations are harder to load it seems).

This unfortunately seems to be an issue localized to your device, so I’ll close this bug report.