Unable to suggest identification

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): using the website on my iPhone

App version number, if a mobile app issue (shown under Settings or About): N/A

Browser, if a website issue (Firefox, Chrome, etc) : Chrome

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: I suggest and identification.

Step 2: I hit the done button to log the ID suggestion

Step 3: the drop down menu of ID suggestions drops down and the done button is non-functional.

I’d really appreciate some help fixing this as it stops me from using iNat to help others with ID.

1 Like

I have been having this same issue also using chrome on an iphone.

Chrome laptop Cape Town - working as intended here now.

Confirm Chrome on Laptop (PC) is working fine.

I had the same problem on the Android App

It would be helpful to know whether people encountering this are on a single observation page, or using the Identify page. Screenshots and URLs are often necessary when investigating bugs.

I should note, though, that the iNat website is not designed for use with mobile browsers, so I wouldn’t expect it to work very well here.

Ok, but I was able to use the iNat site on my phone without this issue for years preceding this recent development.

I experience it on single observation pages, I don’t know what a screenshot will tell you but here is one:

Here is the url and a photo from an occurrence of the reported issue: https://www.inaturalist.org/observations/148421233

I can’t replicate, and I tried both Chrome and Safari on my iPhone 13 Pro. Here are two screen recordings - am I doing something different than you are?


https://photos.app.goo.gl/hctKpAmcLK8oLBbt7 (I later deleted my ID from this observation, so it’s no longer there)

I still have this issue. It looks like we are doing the same thing with different results.

Link to issue.

OK, I think I can replicate consistently now. What causes it is tapping “Done” on the keyboard before tapping “Done” on the observation page. This only happens to me in Chrome, doesn’t happen to me in Safari on my iPhone. Can you try doing what I do in my videos and scroll the window up instead of making the keyboard go away?

I see the same behavior as you are seeing.

This seems to have worked, thanks so much!!!