Inat on Android - cannot load some observations in Explore

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Android

App version number, if a mobile app issue (shown under Settings or About): 1.25.7

Browser, if a website issue (Firefox, Chrome, etc) :

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: I select unknown as the filter and start ID ing the records that appear.

Step 2: after ID ing 5 to 6 records and select a record to ID I just get the green downloading circles and the record does allow me to ID it.

Step 3: if I hold the phone landscape it sometimes finishes the download but will not save the ID I have done.

This has made ID ing a laborious task and is putting me off using iNat.

3 Likes

I never encountered this behaviour.
I have set my app to NOT upload automatically; I upload only manually, when I have finished IDing all that I have in the pipeline.
I also never select unknown first.

I’m sorry, but why are you iding from the app? Even on mobile phones it’s better to user mobile browsers. Ids take time to upload and in browsr you often need to go forward to get it finally saved, I guess app is no different. Try reinstalling the app, but it’s not created to do the id work and maybe it’s something with your phone memory if it starts only after a few observations.

I wouldn’t have the patience to try to use the app to identify observations. Is this your standard way of identifying, or do you also use the website?

I’m having trouble with mobile uploads as well. I have it even with single uploads getting hung up, crashing the app, or duplicating the observation (at least on my end). I’m on Android as well.

I deleted one of the ‘duplicate’ observations and it deleted both. Today I deleted a different duplicate, and it worked fine, though it did duplicate by itself.

I think it might be related to a recent update, since I just downloaded that yesterday and tried uploading a few hours later.

I haven’t had any major bugs for a while, so it seems likely.

My iNat version is 1.25.11, not sure about the Android Version 12 is all I can find (software updated yesterday).

1 Like

I will say that IDing on the app is great for those moments when you’re out and about and need something productive to do with your idle time. :)

That said, I’ve noticed the Android app has been a bit touchy as of late, but haven’t been able to get it down to a solid bug I can report.

Are you aware that you can simply swipe sideways from one observation to the next - i.e. without clicking into and out of each observation? I find it a little more stable that way. The app is not especially well set up for a solid identification session, and I prefer to do it on the website - but I find this helps.

3 Likes

I have the same issues as you. Re: duplicate observations, it’s always best to check that they are duplicates, and not the app bugging by showing the same observation twice by clicking on them and checking the ID number under “Metadata”. It’s not a solution, but work-around until the bug is fixed.

I also find I need to clear the app data every now and again, because it just gets bloated and can’t deal with the amount of memory it’s using. Only do this after it’s finished uploading everything, though.

1 Like

Then it wasn’t a duplicate, it’s a bug of how it just shows observations twice, sometimes one and sometimes many, it’s been known for years but can’t be fixed it seems.

1 Like

I don’t find this reply particularly helpful. If the app nominally allows a user to make identifications, and it begins to fail to do so, that seems like a reasonable thing to make a bug report about.

I also ID from the app (often in short waits like waiting at the bus stop or in line) and for several months this was a fine option. Starting recently I also have experienced this issue where observations don’t load. I have plenty of memory available. I’m running iNat 1.25.7 on Android 12.

1 Like

I changed the title of the bug report to more accurate reflect the specific bug being reported.

This is a known bug and there’s a fix in the current beta version of the app (1.25.12 - 527). I just made several IDs from the Explore page without issues so I think that fix is working. If you want to try the beta version, join the beta testing program here: https://play.google.com/apps/testing/org.inaturalist.android

And yes, the app is not designed to be one’s main avenue for adding IDs but it should work if you want to add IDs with it.

This bug report is about a specific issue when using the Explore section of the app (although it wasn’t clear in the title). The issue you described is very different, so in cases like that it’s best to make a separate bug report or find an existing one that describes the same issue. @marina_gorbunova is correct in that the app will sometimes display the same observation twice - not make two duplicate observations. Best way to fix that for now is to log out of the app and log back in.

1 Like

I think @tiwane’s answer summarizes it, it’s actually easier to use browser on your phone if you want to spend time in unusual place, so my answer doesn’t solve the problem, it’s just explaining that there’s a way to make id process easier, I’m not defending bugs, but trying to help, if it’s not helpful for you, well, maybe it is for other users who started with app.

Thanks, @tiwane and @marina_gorbunova . (Sorry, marina_gorbunova, I think I misinterpreted your first reply.)

1 Like

There is also a separate app for ID only. I hardly use it so I can’t tell you if it is an advantage to use it.
https://forum.inaturalist.org/t/am-looking-for-some-test-users-of-an-identification-app/430

@marina_gorbunova I’ve never seen this bug before, and I’ve been using and uploading on mobile and PC for years.

@tiwane thank you, I’ll do that. I already had deleted the duplicate observation I was referring to, so I won’t be able to get screenshots.

I hadn’t thought to check the metadata for suspected ‘false-duplicates’, that’s a great tip. It did make it confusing that I had 2 types of duplicates, one real and one on the client side only.

Do you clear cache within the app, or just go to ‘Applications’ and delete there? I do suspect there’s some issue with memory as well, since I find lots of ways to crash the app…

I think I did clear cache through the app and I haven’t been getting the duplication error since.

Check here, there’s a link to older one. https://forum.inaturalist.org/t/android-app-shows-duplicate-observations/19767
I think app also shows link to the website, as url will be different/same it’s a clue too.

1 Like