Commit taxon change for my observations not working

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website):

Browser, if a website issue (Firefox, Chrome, etc) :

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:


Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

This may have been a problem for a long time but I’m not sure. I’ve opted out of automatically updating my IDs when taxon changes happen. In a one to one change, I don’t think you should be able to opt out as it is essentially the same ID with a different name. Taxon merges and splits, however, need to be evaluated. I don’t want hundreds of IDs to suddenly be lost or changed to an incorrect ID due to a bad taxon change. So, I keep this setting active to protect the time invested in doing IDs from the effects of bad taxon changes.

When I go to update my content, I see this button, which actually said something about IDs for others the first time I hit it. In both cases, I don’t think any changes were made:

Below that, there are often categories for my content which have numbers by them. In this case there was a 1 by “Identifications for others”. I clicked on that, then select all, and hit the button to update the content. That worked for my identification for others.

My one observation that I had ID’d, however, doesn’t change no matter what I do on the Commit Taxon Change page. It makes me wonder how many other taxa in the past didn’t update from that page. Likewise, it makes me wonder if there is any way to find out.

You can search by IDs for a given taxon, but I don’t know if you can search for active IDs for any inactive taxon. Here are all observations with an active ID for this inactive taxon:
Looks like your only observation is the one you’ve linked to. Interesting that the swap went through on this observation (using this search).

I’m sure there are people who prefer a naming system that is not the one used on iNat.

you can:

… and also summarized (count) by leaf taxon:

1 Like

That worked to at least double-check that there weren’t a bunch of my IDs that needed updating. I fixed most of those but have left the Urtica for now to see if the issue can be resolved.