Uploader not always picking up accuracy

Ok, this may not be a bug on iNat side, but maybe it is (or perhaps I’m missing something). When uploading through the website uploader, positional accuracy is not always captured despite the information being written in the metadata. For example, the accuracy was not captured in this test observation https://www.inaturalist.org/observations/226055036 even though the GPSHPositioningError tag has a value https://www.inaturalist.org/photos/400860159. I’ve tried uploading with Brave and Firefox.

My workflow is a bit complex. I first crop the photos using gThumb and then I write the info in the GPSHPositioningError tag using Exif Tool. It seems that for now, photos edited with gThumb have the problem, but not the ones I do not edit. Still, all photos have the GPSHPositioningError tag OK in the photo info section on iNat, so I would expect the accuracies to be always picked up by the uploader?

Let me know if more details are needed. I haven’t figured out what changes in gThumb when I edit photos.


Are you able to share the photo you uploaded with us, via a service like Dropbox or Google Drive, so we can teast it? (Discourse strips images of metadata).

Here https://cdn.hebergix.com/fr/20240604_075900_00.jpg

Thanks. And this is the edited photo? If so, I can replicate in the web uploader. If i Airdrop the photo to my iPhone and use our native iOS app, it picks up the location accuracy radius.

Yes, it is the edited photo.

Made a Github issue here: https://github.com/inaturalist/inaturalist/issues/4160

Thank you!

1 Like

This should be fixed, that photo’s accuracy value is being picked up in the uploader now.

1 Like

I tried it maybe two hours ago and it wasn’t working yet, but now it is. Thanks!


This topic was automatically closed after 14 hours. New replies are no longer allowed.