Web uploader not recognizing scientific binomials or GPS data in photo metadata

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Safari, Brave, Chrome, Firefox

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: I upload the photos from this page: https://www.inaturalist.org/observations/upload

Step 2: The photos show up with the date and time, and the species name shows in the notes field.

Step 3: The species ID field says “Butterflies” and the location field is blank.

Step 4: I wait and wait and wait. And nothing else happens.

I also tested this on Chrome and Firefox, and got the same result. If I manually copy the species scientific name and paste it into the species ID field, it then populates with the corect ID as displayed in the notes field. Since I have hundreds of photos to upload, I’m hoping I don’t have to manually copy and paste in every species name. For my submissions of photos from the US, both species name and GPS data were picked up (except where iNat couldn’t resolve the species common name).

I put the scientific names into my photo tags and the uploader grabs them successfully. (I haven’t tried putting the name in the photo description. Whatever I write there ends up in the Description field on iNat like you’re seeing.)


In case you haven’t discovered it yet, you can also put observation fields in your photo tags and the iNat uploader will grab those too. For example, if I add “insect life stage=Adult” to a photo tag, the uploader will automatically add “Adult” to the observation field “insect life stage”, and from that it will also automatically add “Adult” to the “Life Stage” Annotation.


I can’t speak for the iNaturalist developers, but it might be relevant to add a screenshot from the application you use to caption your photos. I gather that, for example, you captioned the first photograph uploaded with the text “Adelpha olynthia”. Then, as you observe, the iNaturalist uploader found it and used it as a description, but did not recognise it as a taxon name.

What did your filenames look like? Are they abbreviations assigned by your camera, or did they contain the words “butterflies”, “lepidoptera” or “Papilionoidea”? I normally put scientific names in my filenames, and the iNaturalist Uploader usually uses them. But sometimes it seizes upon a word like “grey” and it decides I must mean the moth Hadena-caesia. I’m not suggesting you should go through the tedious work of copying your captions into the filenames, but existing words in the filename may be a problem.

Losing the location is also a problem, but probably independent of the names. Most of my photos are geotagged by a program that takes a GPX recording of my route and lines up timestamps with the photos. Others are taken on my phone and already have coordinates recorded. But have their locations show up in the uploader, so I agree that yours should be working and it’s puzzling that they don’t. Once again, details of your captioning application may help.

1 Like

I am adding the species ID to the photos’ metadata using Adobe Lightroom Classic. The file names are as given by the camera, often with “edit” appended. As I indicated above, when I submitted photos from within Oregon, using the exact same approach, the iNat web uploader grabbed the GPS point for every submission, and the species name (from the caption field) for every submission except those where it could not resolve the common name. iNat support staff told me that I could avoid these unresolved ID’s by using scientific names, which is what is in the caption field for these photos from central and south America that iNat is having trouble with.

In case it helps, here’s the relevant EXIF/IPTC info from a moth photo I just uploaded, where the iNat Uploader successfully got the taxon name (Eudonia philerga) and GPS and description and observation fields. I use darktable instead of Lightroom but they should be tagging in similar ways. I’m not sure which of several similar fields (eg for creation date) iNat is targetting.

File Name : JJS_5519.jpg
File Type : JPEG
Image Description : Attracted in to a 160W Sylania HSB-BW bulb.
GPS Version ID :
GPS Altitude Ref : Above Sea Level
Date/Time Original : 2022:10:29 21:38:14
Description : Attracted in to a 160W Sylania HSB-BW bulb.
Subject : Geotagged with iPhone 13 mini-Cyclemeter app, 123A Dyers Pass Road, Eudonia philerga, Insect life stage=adult, Method of surveying for invertebrates=Mercury vapor light sheet, moth light
Hierarchical Subject : Geotagged with iPhone 13 mini-Cyclemeter app, 123A Dyers Pass Road, Eudonia philerga, Insect life stage=adult, Method of surveying for invertebrates=Mercury vapor light sheet, moth light
Create Date : 2022:10:29 21:38:14.50
Date/Time Original : 2022:10:29 21:38:14.500
GPS Altitude : 185.3 m Above Sea Level
GPS Latitude : 43 deg 34’ 46.76" S
GPS Longitude : 172 deg 37’ 59.54" E
GPS Latitude Ref : South
GPS Longitude Ref : East
GPS Position : 43 deg 34’ 46.76" S, 172 deg 37’ 59.54"

it’ll be hard for folks to help you in your particular situation without having a copy of your original files. you may want to send iNat staff an e-mail at help@inaturalist.org with a copy of a file that works and a file that doesn’t. that will be the easiest way for someone to actually help you figure out what may be the issue in your case.


seems like this was probably resolved and could be closed now, right?

it looks like lots of observations were uploaded after the previous post here, and it looks like the tags in the observations were loaded in a different way afterwards, which looks like it could have resolved a situation where the relevant metadata hadn’t been mapped to the fields that iNat was looking for to populate various fields in the observation.