iNaturalist website isn't opening

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Microsoft Bing (Edit: It seems to be happening on any search engine I try to use).

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:
Screenshot 2022-10-16 152326

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Try to open the website.

Step 2: It doesn’t work.

Every time I try to open the iNaturalist website, it doesn’t seem to want to work. This problem has never happened before for me.

1 Like

Have you tried checking your device or network for a firewall? It opens fine for me from Bing, Google, and DuckDuckGo in Firefox.

Which browser are you using, and which device are you on?

Same here, no problems.

1 Like

I was about to check on the firewall, but the website seems to open now. I wonder what was making it not open for the last two days.

New problem: A bunch of information on the website isn’t loading. Also, I’m on a Windows 10 PC using Microsoft Bing. (Some pictures below showing the things that won’t load). Edit: The website stopped working again, and the firewall doesn’t seem to be affecting it. Edit 2: The website is back, and things are loading. I don’t know why it’s freaking out on my computer, but it seems to come back at least if I wait a bit.

Observation pages aren’t loading.

Specific observations won’t load.

Miscellaneous information like graphs, leaderboards, total observation count, etc. won’t load.

I can’t give you a why, but I had a few days when iNat photos were hidden. Not even taking forever to load. Can’t iNat without photos!
Now mine is working again as it should.

As far as I’m aware, Bing is not a browser - it’s a search engine you can load in your browser. Common browsers are Firefox, Edge, Chrome, and Safari. Do you know which browser you’re using?

The next time you come across a page where elements don’t load, can you please open your browser’s console and share a screenshot? It should contain any errors your browser encounters. Here are instructions for opening the console on most major browsers.

Please include the URL of the page as well.

It appears to be Edge.

OK. Then please provide a screenshot that includes console the next time this happens. It’s working fine for me when using Edge on my Mac. Have you tried turning off extensions in your browser?