When I click on Your Observations in Windows, I don't get the Grid of My Observations

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Microsoft Edge

URLs (aka web addresses) of any relevant observations or pages: This comes up when I click on Your Observations; not what I want to see.

Observations · iNaturalist Canada

As a clumsy work-around, I click on Edit Observations and this page comes up:

Edit Observations · iNaturalist Canada

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

When I click on Your Observations to see my observations in a grid from newest to oldest, I get the page shown in the first screenshot above. This is not okay.

Step 1: Click on iNaturalist logo.

Step 2: Click on Your Observations. This used to bring up a grid of my observations in order of newest to oldest. Starting on July 8 or 9, it no longer did that. It opened at the window shown in the first screenshot above.

Step 3: Alternatively, repeat steps and click on iNaturalist logo.

Step 4: Click on Edit Observations. That brings up a list of my observations in list form. Not ideal. Difficult to see and work with.

I don’t think this is a bug. The Explore window offers different views.

Have you tried clicking on the “Grid” or “List” buttons in the upper left of the Explore window?

They should give you the different layouts you are looking for.

The view is “sticky” meaning that it will display with the last view that you used. This means you likely selected a map view previously, and the view is showing you that now. If you select one of the other two views, that will become “stuck” until you switch it.


That worked! Thank you! I will bookmark this answer in case it happens again.