Android app not reading picture location data

Hi tiwane,

I am having this exact same issue. I have confirmed that my location permissions are on for both the iNat app and my photo app. The location is indeed located within the meta data of my photos but iNat just isn’t pulling it.

I would be willing to try the fix mentioned.


1 Like

OK. The fix is further up this thread:

Which version of Android OS is your device running?

I’m experiencing the same issue. Samsung Galaxy S22 Ultra with Android 13 on Verizon. iNat app version 1.29.3 (577). Phone auto updated to use new photo picker, and location is no longer read from photos (even though present in EXIF). The workaround mentioned earlier by @ncb1221 solves the issue (thanks!) Unfortunately, I probably cannot beta test the fix as this is a locked corporate device.


It looks as though the new photo picker has been rolled out to some other devices now - we’ve been more getting reports like yours this week, @rupertclayton.

1 Like

Same issue. Glad it’s not just me. The @ncb1221 “browse” workaround bypasses the issue, but happy to test a different fix.

I have a Pixel 7 Pro. I replaced my SIM card recently and I thought this problem was associated with system reset, change in app settings, etc, but couldn’t find anything out of line is app permissions. Weird.

We’re investigating a long term fix. It’s frustrating that Google says they won’t change the way their new photo picker works.

In iOS we use Apple’s system-level picker, which means the iNat app only sees photos you choose to import into the app, so there’s some privacy protection there. The Apple picker includes location data though, which I think is a good compromise.

@ncb1221 's solution is working for my Samsung S22 Ultra. Thanks very much

So weirdly and frustratingly, I seemingly have lost the “browse” workaround. It changed just this morning.

Edit: it is pulling in the coordinates now, which is good. The drawback is that the photo picker still doesn’t seem to have a path to access the android Photos app to access pics more than the 30-40 most recent photos.

Are you a beta tester? Which version of the app are you using?

1.29.7 (581)

OK, that’s the latest beta, so you’re a beta tester. You can always opt out of beta testing in the Google Play Store, just go to the iNat page.

I also tested that version on a new Pixel device and found similar bugs, which I’ve reported to our developer.

1 Like

I suddenly noticed this for the first time this afternoon. I’m on a Pixel 7 Pro. I still have access to the Browse workaround for now.

Strangely, according to my phone, the last iNat update on my device was August 4th and the last Android update was August 5th…

Why is that strange?

I’m having the same problem as OP. I’m using a Google Pixel 6, uploading photos taken with my phone camera (gps/location enabled). Historically iNat has automatically grabbed the location data but in the last month or so I’ve noticed it stopped automatically importing. Anyone else experiencing this or find a work around?


After posting this I had an idea and it solved the problem: upload the photos by browsing instead of directly from the in-app gallery.

Here is the workflow I used:
Step 1: Take a photo with my phone camera, gps/location enabled.

Step 2: Open iNat, click the + on lower right of home screen.

Step 3: Select “Choose Image” from option dialog

Step 4: Click on the 3 dot menu button on the upper right of the “choose image” screen. Click “Browse…”

Step 5: Choose one or more images directly from my phone gallery.

Step 6: a new “Edit Observation” instance is created and the location is now filled in.


this should probably be merged with

1 Like

Welcome to the forum! I merged your post with this existing one which seems to discuss the same issue - it looks like you found the workaround that is working for folks now until the issue with the new Adroid photo picker is dealt with.

1 Like

Same error to tecno POVA 4
En mi dispositivo sale error antes tenía un Xiaomi y me iba perfecto, ahora uso en Laptop para subir :c

I use a Pixel 5a and have had the same issue. My workaround of choice is to share the photos from the Google Photos app to iNaturalist.

1 Like

I’m on a Pixel 4a, having the same issue suddenly. The workarounds work. (It had never occurred to me to start an obs from Photos by sharing to iNat, that’s pretty easy!)

I’d be willing to beta test a fix but not until after this weekend. I’m running a mushroom foray for 100 people, with many heavy iNat users - so I’m very glad to have found a decently easy workaround that I can share with people!