App won't open on iPhone 7

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): iOS 15.8 on an iPhone 7

App version number, if a mobile app issue (shown under Settings or About): ? Downloaded the most recent update after I noticed this problem, but did not remedy the problem.

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.): When I try to open the app, I get an “Updating Database” screen, then app quits. According to the phone, I have the most recent update for the iNat app.

Step 1: Touch app icon

Step 2: Watch “Updating Database” green screen with bird icon appear for a fraction of a second, then disappear.
Worked fine yesterday with same OS.

This looks similar to a previous issue:
However, those were with a different iOS version (12.5.7), so I’ve let as a separate bug report for now.

That issue hasn’t been resolved to the best of my knowledge due to lack of info and that no one could become a beta tester due to iOS being pre v13. But since iOS is >= 13 here, maybe beta testing will help, see

Call Apple help desk. They helped me with the same problem.

Wow, good service! What did the help desk tell you to do?

Probably the best fix would be to delete and reinstall the app - something in the database is likely corrupted.

1 Like

Thanks. Deleting and reinstalling worked.