Upload and batch annotations interfaces garbled

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Mac 10.11.6 (El Capitan)

App version number, if a mobile app issue (shown under Settings): N/A

Browser, if a website issue (Firefox, Chrome, etc) : Safari and Chrome

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):
Title says it all - online (desktop) upload, batch annotation, and location selection pages aren’t loading correctly, as shown in screenshot (only one allowed!). Same behavior in Safari (11.1.2) and Chrome (84.0.4147.89).

I also notice that for location annotations it’s no longer searching my pinned locations, but just searching the web as I type location names. I don’t know if this is related to the above problem, or distinct.

I don’t see any other reports of these issues, so I don’t know what to make of them.

Mike C.

1 Like

Thanks for the report, Mike. A few questions:

  • This doesn’t happen on any other parts of the site, just the upload page? (I’m assuming by "batch annotation and location selection you don’t mean separate pages, just the pop-ups on this page).

  • This happens consistently?

  • Can you please open up the console in your browser when you’re seeing this and send us a screenshot that includes the console? If there is red text in the console, that’s what we’re looking for. This page has instructions for how to view the console for the most common browsers: https://support.airtable.com/hc/en-us/articles/232313848-How-to-open-the-developer-console It’s a little easier in Chrome than Safari.

The batch annotations page seems to be a different page that show all the images I just tried to upload (by drag and drop, which worked). Maybe it is just a pop-up, but it occupies the entire window. The add locations page I guess does seem more like a pop-up.

I haven’t attempted to do anything along these lines in a couple months, but everything’s worked fine previously. Today (noon to today) has been the same story.

I do see the red console text indicating expired security certificates. This could be that a browser update changed my security settings without my consent, as I have had to override a lot of safari’s objections lately.

I’m still told as a new forum user I can only attach one image:

1 Like

Thanks, it looks like the same issue as in this bug report. Maybe try @brandonwoo’s solution here for now.

We’ll look into a more stable and long-term fix.

Yep. That fixed it. Thanks!

Great! I’ll close this report.