Cannot add taxon images

I cannot add images to new taxa. I uploaded JPGs and PNGs to Flickr and made them public. When I try to add an image to a new taxon, I can find the image with a search using Flickr and I can drag it from the left pane to the right pane but it is not added to the taxon.

Do you click save? What happens next?

I did. There is no error message. When I get back to the taxon, no image has been added. I have tried with two newly created species.One example


I want to add

I tried the add image way and also adding a Flickr image ID when I create the species but I don’t know where to find the Flickr image ID…

What am I missing?
Why not make an obs using your image … then you can use your image easily

I agree with @dianastuder, while it’s being investigated, why don’t you use iNat photos?

1 Like

Diana & Marina. Thanks for the suggestion. Both taxa have had only one new observation each. In both, the images that were posted are not good enough or do not show relevant characters well enough. Additionally, I have an image I made that helps separate two very similar species.

Is it a rare species? Otherwise, once the taxon is available on iNat new obs will trickle in, and then you can adjust the taxon photos as the quality improves.

(I defer to you - but I prefer the taxon photos to be sourced from within iNat where we have quality control of species agreement)

Yes, both are very rare. First observations and maybe no further ones for years.

1 Like

But you posted images to flickr, so they must be your photos? Then why don’t you upload them? If they weren’t collected by you, upload them as captive.

iNatters can do patience for years … still waiting for the relevant scientists to describe our Table Mountain strawberry (spider) But we have pictures :grin:

1 Like

Agreed, I’ve done patience for a decade for some of these. The images are mine. While species descriptions and DNA work is in progress, I do not want to make known the type localities.

For the one which provides distinguishing characters I can post an observation and include this image and then source it from iNat for the taxon images. So that’s a good suggestion you made.

Staff have just confirmed that they can replicate my problem. So, a solution may be soon in sight. Again, thanks for your help, both.

1 Like

You can upload with hidden place, or with none at all.

1 Like

I’ll consider that but I’m trying to avoid it since it makes it hard to ask users to provide more precision with their observations if I provide no location at all…

It’s different and you can add it later, as obscured or open, after you publish.

1 Like

No - you have a very good and valid reason to obscure the location.

You can also Flag for Curation, and ask to have that taxon obscured by iNat by default. With observers choosing to make the hidden coordinates visible to you.

I will remember the processes that you both described and they will surely come in handy in the future. For my current cases, I’ll wait for staff to fix the error. Thanks much for the quick replies and the great help you provided. Happy rest of holidays!

1 Like

Made an issue here:

@tiwane This issue has not been resolved. I still cannot add any images to a taxon. I tried in Chrome and in Firefox and I’ve tested it in the V2 API with the same effect, no images added. Can this be escalated? Cheers,

It’s near the top of the list of our web bugs for priority. But have a limited amount of staff time to dedicate to web developement at the moment.