Cannot log in with saved password on Mac

This problem is on a MacMini OS10.12.6
Safari 12.1.1

All is as expected on my iMac 10.11.6, Safari 11.1.2.

Since the last iPhone update a week or two ago (yes, I updated it and the iNat app too) I have not been able to log in to upload to the iNaturalist app, or to log in at all to in Safari, on my iPhone.

I don’t know how long it has been since I logged in on the MacMini, and I may have changed my password for some reason since it last saved it.

Today iNat website opens with the log in page, my user name is there, but no pw. When I click on the pw field, a hidden pw pops up as usual (looks like the right length), but disappears immediately. (So I can’t screen shot it).

Requesting pw reset instructions results in a msg that pw reset instructions will be emailed shortly. No email results (at least 15-30 minutes? I have been doing other things.)

With the latest iPhone update, I was asked to “complete update” by doing something with the words “iCloud keychain”. I initially declined, since iCloud presents problems for me in accessing and deleting my iPhone photos, and I have disabled it as back up. LAter, in case it was the problem here, I accepted the “Complete update” request.
iPhone SE MP852X/A, iOS 13.1.3 iCloud Keychain is “on” on my iPhone.

NB I don’t know how iCloud or the password keychain work, and have only had an iPhone for a year, so I may have done something to disrupt the flow of info somewhere.

An hour ago I tried logging in to the website on the MacMini and it declined the saved password. I requestd an email with pw change instructions, but no email has arrived.

In summary: I can log in as usual with the password saved on my iMac. (I don’t know what it is).

I can’t log in to the website on the MacMini or iPhone.

My iPhone logs in automatically to iNaturalist app, showing my Profile, my Obs and activity, but demands “Sign In” before uploading, and I have the known bug that prevents Sign In.

I cannot obtain the pw change directions email.

I cannot find the details of my iNat version or update. It was within the last two weeks, and as recommended in the forum after the iOS update.

1 Like

I don’t think this password issue a bug with iNaturalist, but with iCloud.

Probably best to delete the app and reinstall it to fix this bug.

Looks like our email service dropped your address from its rolls “because the email address previously bounced”, so none of the emails are actually being sent to your address. It’s likely your email provider thinks that emails from iNat are spam and is refusing them. I’ve removed your email address from the bounce list, but I would recommend adding to your contacts list, that might help them get through.

If that doesn’t work, you might have to try a different email address. Message with a different email address we can use for your account.



That’s what I suspected. I loathe what I DID finally get to know of iCloud’s workings with a passion.

I will see if i can do what you suggest, thanks Tony.

1 Like

But I have been told there is a known bug re the iPhone perpetual sign-in issue to upload in the iNat app, I have another thread about that and I understood they are working on it?

1 Like

I deleted the iNt app from my phone and installed a fresh download. Unfortunately I can’t log into it because I don’t know my password.

I have emailed help@inaturalist but as i don’t have another email address that I can readily access I asked if they could reinstate my email address. I got a funny email some hours later; it had text with wrong characters and missing icons or images I think, but it appeared to be some of my iNat alerts in a format that didn’t work on my computer. I have not previously received automatic - or perhaps any -emails from iNat - that is one of the things i love about it:) - but maybe it was because they never had my email address? I wonder if I had to use a google email or something to sign up to inat, as have done occasionally when I needed for other websites? I had some problems a year or two ago with google that i could not solve except by closing my account which i did.

I tried requesting the Reset password email again from my Macmini. I prompty received the email, followed the link and tried resetting my password but it didn’t “take”. It was similar the problem on my iPhone when I was already logged in and tried to upload -it didn’t accept the entry into the field.

I can’t try resetting my password on my iMc because I don’t have email on it. OR can I? I am scared to try anything else, because I am working 6-8 hrs a day on iNat with a deadline and if I lose access on the iMac i am in big trouble:)

I will take my phone to a phone shop tomorrow and see if they can advise me about how to circumvent, remove or correct the password chain that appears to be affecting my access on the MacMini. Is there any advice I should give them to avoid being left without access after whatever they do?

@tiwane How far away is the next update which fixes the iPhone problem?

By “the iPhone problem” I assume you mean the bug where you get the Log In screen when you try to upload an observation? The latest update in the App Store (released yesterday) has code that should prevent it, or at least minimize it.

To be clear, we had your email address but our email service stopped sending emails to it because they had previously been rejected. It’s good you’re receiving emails now, so at least that part of the puzzle seems to be solved.

Without specific details or a screenshot, I’m not sure what you mean here. Please be as specific as possible, terms like “didn’t take” are not easy to parse. Something like “when I entered a password I received an error message that said _____” plus a screenshot make troubleshooting much easier.

Great, thanks!

When I follow the reset pw link I can enter a password, then i get amsg to choose whether to update iClud keychain. Whether I choose yes or no, then click “Change password”, the entered pw disappears and the pw “new” and “confirm” fields are once again blank.

I have also tried accepting the “strong pw” entered by Safari. (Relucntantly, since I won’t be able to remember it).

The result is the same. Fields become blank again.

I have just downloaded the latest iNat update to my phone. Then I came to my MacMini and followed a fresh link to pw reset. I chose not to use “Strong pw” automatically suggested.

This PW change seems to have been successful, for that computer anyway, I asked it to remember the pw, and then logged into iNat on that computer.

Then I opened Safari on this iMac, holding my breath. I was still, or automatically? logged in, as half an hour ago. If a later login is unsuccessful, presumably I will need to use the new pw, which I have written down.

Have you tried another browser? Keychain is an Apple thing, so you shouldn’t get a Keychain pop-up if you use Firefox or Chrome. At this point it seems like Keychain and not iNat is the main issue.

Password managers are fantastic and can help you be a lot more secure, but they can be funky to mange. I’ve been using 1Password for years and can’t get it to sync correctly to my iPhone, which is infuriating.

1 Like

Thanks Tony. I felt like keychain was the problem, but don’t know how to manage it.

At this point all my devices seem to be accessing iNat (as App on Android tablet and iPhone) and via Safari on my Macs.

And I have the working pw written down:)

That would be infuriating, yes! I also had used 1 pw for years until I got an iPhone…sigh.

Thanks for your help. I will add a comment to the forum when I am sure everything is working.


Resolved since the last iNat update. I am still using Safari and must have managed to avoid mucking up the keychain so far:) but I will your remember your tip about other browsers, thanks Tony.