Can't see maps in China

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform : Website

Browser : Chrome, IE, Edge

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem Can’t see maps in the past few days. I’m in China and using VPN. Nothing changes after I change other VPN/ computers

It sounds more as a VPN issue for me, it’s definitely because of Google ban, maybe you should try another one.

1 Like

I tried 3 different ones. I think someone made some changes to the map system. Before when I select “China” in the filter it would include area around China. Now it only shows mainland China.

BTW google map works well with my VPN

I see this now if I choose China in main location chooser (and see contour in place chooser).
That is weird, maybe it is because something was changed in coding.

That’s exactly what I saw before. But now it look like this:

The main location chooser is not working, I have to set up location in the filter

In the filters it always shows it that way, main thing is why it’s not working for you as it should be.

I think it still relates to the map. Even the world map is unavailable.

go to a page where you’re seeing missing maps, open your browser’s developer tools, and go to the network section. reload the page, and see if anything is being logged in red in either network or console.

Like this?

I’m right nearby in northern Vietnam and there are no problems viewing maps and/or observations in China with or without a VPN.

None of my VPNs have China as an option, so I can’t try it that way.

Have you tried using a different browser from your primary one? Often I’ll find chat Chrome gets buggy and messes up certain websites. I kept getting error messages on the USGS/EROS website in Chome and was unable to login, but there were no problems at all doing so via Firefox.

I tried Chrome, IE, Edge, QQ, and Firefox. All 5 of them have the same problem. I’ll try a different Internet service provider tomorrow and see if anything changes

yeah. like that.

something preventing Google from sending you maps, but i’m not sure what the problem is.

i would try a couple of things:

  1. do you still see the same problem in private browsing mode?
  2. if you set your browser language to English first, do you still see any issues?
  3. if you set your iNaturalist profile to English, do you still see any issues?

if you still see issues, then i would guess it’s your VPN or ISP…


The map works after I change a new router…This is interesting…


Thanks everyone!

1 Like