Location screen turns white

I’m trying to make my first observation, so the bug is probably a user error.
I upload a photo (on my computer), add in the species name and date, but when I go to location- whether I type in the town name or click on a spot on the map, the computer screen goes all white and hangs up.

I can’t get past this point. I’m in New York, trying to make observations from last summer in Ecuador.
Using Chrome and windows.

1 Like

Could you please make screenshots of what you see?

1 Like

I don’t think it will be very helpful as it’s an all white screen…

1 Like

It’s very weird, I try what you described on Chrome and don’t get this grey screen. This grey thing can happen when you scroll map, but never saw it being on whole screen like that.
Also maybe exact shade of grey is the background of upload page itself.

@pisum could you help us here please?

1 Like

Can you open up your browser’s console (Control + Shift + J), trigger the issue again, and take a screenshot that includes the console? That should display any errors being recorded by the browser.

Also, it looks like you have some adblocker extensions (screenshots are always better than no screenshots :wink:) - I’d try disabling those and see if that makes a difference.


Yeah, that made a whole ton of error messages. I had already fixed the adblocker.


I am able to get it to work in Microsoft Edge, but would really rather stay in Chrome if anyone has a solution

What town are you entering? We need as many specific details as possible to try and replicate the issue on our end.

If it works in Edge but not Chrome, it still seems like an extension issue to me. Have you tried turning off all of your extensions in Chrome? Doing that, seeing if it works, and then turning them on one by one and testing each time is usually the best way find out which extension is causing the problem.


I turned off all the extensions in chrome and it still doesn’t work.

The town I was typing was Nanegal, Ecuador. I also tried zooming in on the location on the map.

I also tried to add an observation near my location in New York and had the same result.

It’s translating the page from spanish- not sure if that could cause a problem.

1 Like

Try turning it off too. Or maybe update the browser if it’s possible?
I see this location working for me:

It didn’t seem to have any effect.

I notice you are at inaturalist.org. I am at ecuador.inaturalist.org
I’m not really clear on what the difference is in this application…

Hm, try logging in to main website, maybe it’s something related to this? You can log in with same account.

OK, I have it working. I thought I had translation turned off before, but maybe not. I have it off now and uploaded to both inaturalist and ecuador.inaturalist.

The regular inaturalist page was showing it to me in spanish and quickly translating to english. How can I get to english as my default language?

Nevermind! Found it under “bill” which was the last place I looked :-)


I’m glad it’s finally working for you!

1 Like