Can't upload specific images. Editing mode gets skipped

Platform (Android, iOS, Website): Android 10

App version number, if a mobile app issue (shown under Settings): 1.19.0 (422)

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

App turns white and skips editing mode when I try to upload specific images (see attached) and they show up as unknown (see screenshot).!

Step 1: Select one or more images

Step 2: Share them with the iNat app


Works fine with other images on your phone?

Yes, no problems at all.

All three photos worked for me in Android app version 1.19.0, either singly or all in one observation. (Obviously I deleted them after testing.)

for what it’s worth, i do see 2 observations with photos that look like ones from the set posted above:

i also wonder why these are being loaded as separate observations instead of one observation with multiple photos?

Because I tried several times and I didn’t delete all failed observations.

I’ve made a screen recording to demonstrate the issue. First tries with one of the mentioned images don’t work. The others work though.

first, for someone to properly troubleshoot this, you will probably have to e-mail or provide originals of the photos in a shared location. loading the photos to this forum will strip all the metadata from the photos (for privacy, i assume).

but now back to the subject of 1 observation with multiple photos vs. many observations. it looks like you were able to successfully create at least one observation for the bird. have you tried to open up a successful observation and add the additional photos from there?

1 Like

I think Discourse strips metadata from the photos (at least it has for photos I’ve uploaded). @iPhil can you share a dropbox or google drive link to the photos, or email them to It would also be helpful if you can send some log files to us as well.

To send log files, go to the Settings tab in the app and tap three times on the version number. You will then have the option to email the log files to us.


At some point the images get uploaded but with stripped metadata.

I have emailed the log files and a sample image.

1 Like

Thanks @iPhil, I was able to replicate the issue. I’ll let our Android developer know.

looks like this was fixed? time to close?

observation with 4 photos loaded:
possible bug fix in Android app:

1 Like

Yes, working for me in build 425.

1 Like