Clicking "View on Google Maps" on an observation no longer directs to observation location in Maps (Chrome on Android)

Platform (Android, iOS, Website): Android

App version number, if a mobile app issue (shown under Settings or About): NA

Browser, if a website issue (Firefox, Chrome, etc) : Chrome

URLs of any relevant observations or pages: Any

Description of problem: When on an observation page under the location details, Clicking “View on Google” opens Google Maps but only opens to the default screen (your location on map) and does not adjust to the location of the observation.

Step 1: On Chrome over mobile, open any observation and click “View on Google” under location details.

Step 2: Google Maps app opens as it would if opening app from home screen

Step 3: Location does not update to the location of the observation

I’m not sure if this is an iNat issue but figured I would ask, it’s always worked fine in the past. I cleared all app data and my cache for Maps, force stopped/disabled and reenabled the Maps app with no luck (app was packaged with Pixel phone and unable to uninstall/reinstall)

1 Like

I checked with Chrome on Windows just to see if there was an issue there, and there is not - works as expected opening, so maybe just restricted to mobile/Android. I wonder if it’s something to do with the formatting of the link from iNat or maybe the Google Maps app has changed how it handles links?

I pulled my most recent obs to test, and this is the link from the web browser:,-71.4714380986

which opens in Google Maps. Does that open ok on your phone?


That link did not work for me and behaved exactly as it would if I had clicked view on Google in an observation (opened maps but did not go to observation location).

I should have thought to do this before but I just checked other websites to see if their links directed and the two I checked worked fine which were a trail at a local land trust from both Google and their website's+and+spectacle+pond+falmouth+ma&client=ms-android-google&sxsrf=AB5stBgGONRGYgjYSIggK-eLn9ndazLQGA%3A1688747765947&ei=9T6oZJe1OfCr5NoP3PyquAI&oq=mare's+and+spectacle+pond+falmouth+ma&gs_lcp=ChNtb2JpbGUtZ3dzLXdpei1zZXJwEAMyBQghEKABMgUIIRCrAjIFCCEQqwI6CAgAEKIEELADSgQIQRgBUIAKWJIaYPwcaABwAHgAgAGKAYgBkwqSAQM3LjaYAQCgAQHAAQHIAQM&sclient=mobile-gws-wiz-serp&bshm=lbse/2

1 Like

I can replicate with a Pixel 3a. But if I open the link in a new browser tab it works.


Same phone, maybe it’s that time where things slowly stop working to try to get us to buy newer phones…

Made a Github issue here:

Thanks @tiwane !

1 Like

No problem. Also we don’t mark a bug as “solved” until the fix is actually released. Making a github issue just makes a more formal report of the bug to our devs.


Having the exact same issue. Dont think it is a link format problem as if you hold down on link and select open in new tab, it works fine. Just wont do it in the parent window

has the Android GMaps app ever handled those links? i think it expects a format like this:,-71.471444

I want to say yes as I can’t recall running into this issue in the past and I’ve used this to get locations in the field when looking for species I’d previously observed.

In the last couple months Chrome (for Android) changed the way it handled new tabs; previously a new tab would open in the same group whereas now it does not. Given that the issue seems to be alleviated when opening in a new tab, I wonder if it may have something to do with how Chrome is handling things.

when you open in a new tab, the page opens in the browser. otherwise, it probably gets redirected and the location opens up in the Google Maps app.

there’s no question that the web page in the browser is working and has always worked. it’s just a question of whether the GMaps app has always handled those kinds of links the same way.

regardless, the format of the link i provided above should produce the expected results in both the web and the GMaps app.

1 Like