Explore function in app not working

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website):
App version number, if a mobile app issue (shown under Settings or About):
version 1.28.0
Browser, if a website issue (Firefox, Chrome, etc) :
URLs (aka web addresses) of any relevant observations or pages:
Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices: https://www.take-a-screenshot.org/):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: open inat app

Step 2: click on explore

Step 3: exploring all, my location - no observations load. Loading circle continuously shown …can’t filter or change location etc.

Have cleared cache, reinstalled app, restarted phone etc. Has been happening for about a week.

1 Like

Experienced same few more than 12 hrs ago

since you’re exploring in your location, could it be possible that either the app can’t access your location for some reason, or you’re at a location where there aren’t any observations?

if you turn off your location services and then restart the app and then go to the Explore page (thereby forcing it to get all observations regardless of your location), do you get any results back?

I didn’t think much of it at the time but I got the same results on the iPhone app last week when I looked for amphibians on Galveston island. And there are definitely records. Restarting the app seemed to fix it though

1 Like

I’m glad you filled out a bug report for this. I’ve been meaning to but didn’t get around to it.

I’ve had exactly the same problem on the Android app for over a week now. At first I assumed poor connection but I’ve tried it in three different countries on good wifi and mobile data connections with the same result. i’ve turned my phone’s location off and on and reinstalled the app but no luck.

hmmm… so if you still have the same problem with location off, then it does seem like there could be a problem in your connection somewhere.

are you able to open up an individual observation in your app?

here’s one of mine for easy access: https://www.inaturalist.org/observations/137315826.

Since I’ve tried on many different wifi networks and mobile data in different locations (where the internet connection and location services work perfectly for everything else) and I still get the same result that @haczech has described then I suspect it is an app issue and not my connection.

Everything else in the app works just fine, it’s only the explore function that doesn’t.

ok. if everything else is working, then you may want to send a log file from your app to help@inaturalist.org then. i’m not able to reproduce the issue you all are noting. so it’s possible that the staff won’t be able to reproduce either. so they’ll need to see your log files to help them figure out what’s happening in your case. in the Android app, you would go to the About screen and tap the version number 3 times.

1 Like

This is a beta version of the app - are you all beta testers?

The latest beta has a bunch of updates and has a lot of bugs (including this one) so if you don’t want to suffer through them as we fix them I recommend either leaving the beta program for a bit or, if you don’t want to leave the beta program, uninstall 1.2.8 and download and install the APK file of the most recent public release here.


I’ve tried turning my location services on and off and tried access from multiple locations. I’m in an area with manymany observations. Interestingly, the map of locations works just not the list. I tried specifying taxa, like amphibians only, and the app just crashes.

Ah just saw the note about beta. Yes I am a beta tester.

Thanks @tiwane, the apk download fixed the problem!

1 Like

Fixed in the latest beta: 1.28.1 (554).