On Android app, web links don't open in app, despite "default app" being set for links

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Android

App version number, if a mobile app issue (shown under Settings or About): All versions (including latest)

Browser, if a website issue (Firefox, Chrome, etc) : Chrome

URLs (aka web addresses) of any relevant observations or pages: All

Description of problem : On Android in Chrome, links to iNat don’t open up the iNat app, even if the Default App is set correctly for the website. Is there no way for iNat Chrome links on Android to open the app?

Update: I cleared cache, cleared data, uninstalled, reinstalled, and tried this again.
Still doesn’t work.

Any developers on the Android app out there?

  • Tim

What’s one of the URLs you’re trying to open?

@tiwane Here’s one… basically I want to use this type of link for using the explore function as a saved search (since saved searches aren’t a feature of the site or app).


@tiwane Were you able to verify that the above link doesn’t open the app in Android?

Yes, it doesn’t open in the app, but that’s expected. The app will open individual observation pages, but not search pages or taxon pages. So it’s not a bug.

Reopened because @tbessie wanted to respond.

This topic was automatically closed after 2 days. New replies are no longer allowed.