Client error (422)


2.8.7, build 558

Attempting to upload 5 observations. Receiving a Client Error (422).

These observations are not part of any project.

1 Like


Had the same issue just now. The observations uploaded without photos but the app didn’t reflect that until I reinstalled it.


Adding the photos back to the photo-less observation and reuploading seems to work fine


Sorry folks, this is my fault. I deployed some code a little while ago that caused these 422 errors I believe only on the iPhone app. The code was reverted after about 15 minutes, but any observations that people tried to upload during that time likely saw this 422 error and got stuck in a broken state. I’d try the approach mws suggested, or deleting the observation and recreating it worked for me. Apologies for the error and the need to clean the broken observations. Hopefully all new observations upload successfully now.


Any way I can get the ones on my phone uploaded without having to recreate them or re add photos? I’ve got 105 observations and the gps is too important on these to use the location tagged in the photo info which is often wrong :(

1 Like

If anyone else had a lot of observations waiting to upload and saw this error - it might be that only some observations were affected and they are preventing an entire sync from happening. I recommend pressing the upload button on each observation individually to see if they will upload, and then trying the other approaches for ones that remain stuck.


A post was split to a new topic: Error 422 on iOS