Community ID doesnt change even though all identifiers agree on the same taxon due to number of tags

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

App version number, if a mobile app issue (shown under Settings or About): -

Browser, if a website issue (Firefox, Chrome, etc) : Firefox

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):

Step 1: Go to

Step 2: Suggest a supporting/agreeing ID

Step 3: The community ID still remains “Lycosidae”, which is what the observer initially suggest and has since withdrawn

1 Like

it appears also impossible to vote on “Based on the evidence, can the Community Taxon still be confirmed or improved?”
something does seem bugged here.


@naufalurfi, it appears that you voted “yes” on “can the Community Taxon still be confirmed or improved?” Can you retract that vote? That might solve the issue.

I tried voting no to counteract it, and my vote wouldn’t ‘stick’ at all. Nor would voting yes. So i do think there’s additional bugginess here or something.

I actually thought voting it would solve the problem, but when i did it didnt register at first. Now instead it doesnt do anything when i clicked to retract the vote.

Anyways the other observation ( doesnt have any of that vote and the prolem is still there

I added an agreeing ID, and then clicked and unclicked “organism is wild” - now it is research grade at family level somehow?? I also tried to add an “ID can be improved” vote and could not.

Edit to add: I notice both of these are uploaded via Flickr, in case that has anything to do with it.

Sounds like this bug?

Based on Loarie’s comment on this observation it seems like the issue may be related to the user having too many tags on the observation?
In which case, it already has a github entry from a couple of years ago:


Yes, it’s related to the tags. We instituted a tag check on upload to prevent this from happening about two weeks after this observation was posted. I’ll have to play around with it on our test server to see exactly what’s causing the issue and then reach out to the observer to see if they want to remove any of their tags.


Holy crap that is a lot of tags.


I think I may have some observations with a similar plethora of tags from Flickr imports. The taxonomy tags look like machine-readable tags that were added on Flickr to facilitate import for some other sites, e.g.

It also still says “The Community ID requires at least two identifications” under the community taxon.

It seems counterintuitive that tags would affect this since they are separate from the identifications.

Basically there’s an overall character limit to the tags section of an observation. If the limit is breached, then the observation can’t completely save.


So it sounds like the bug is that the tag limit doesn’t always get enforced correctly?

At the time this was uploaded we weren’t running checks to see if the limit was breached because I don’t think we expected it to be breached. We added a check on upload about two weeks after this observation was uploaded.