Community Taxon doesn't exist even though there is more than 1 ID (Rumina decollata)

This is clearly a bug with one particular taxon, Rumina decollata. A significant number of observations don’t have a Community Taxon, even though there is more than one ID. This keeps observations at Needs ID when they should be Research Grade. Reindexing the observation doesn’t help (through adding annotations, DQA votes, etc.), but adding an ID does fix it. with many more on Identify.

When I’ve had weird issues like this before, often deactivating and reactivating the taxon in question (and sometimes the parent also) will fix things. Sometimes it has to be done several times. When I first saw this issue, there were 24 pages of observations of Needs ID on Identify. I deactivated/reactivated and it went down to 6, but there were still some observations left over so I did it again. Then the pages went up to 23 and back down to 10. Obviously this wasn’t really helping that much so I stopped.

There were weird issues with this taxon before, but deactivating/reactivating fixed them (see this flag). There seems to be something off with the taxon, and it could be that changing the parent at some point made things weird, but there are no swaps so I’m not sure where else things could have gone wrong.

Using Chrome on a Mac


Paging through these, it seems like maybe the problem is only with older observations, added ~3 years+ ago. Does that match what you’re seeing? If so, maybe we can’t explain it, but if it’s not happening to new observations (I haven’t seen this happen with any of mine, for example) we could fix it just by adding another ID throughout.

Yes I had noticed that, but there seem to be ways to change it so that observations that were fine get reverted back to the bug. Perhaps I could go through and reID every observation of the whole species, but I don’t really think that’s worth it.

Also It looks like changing the DQA on my linked observation may have fixed it (even though when I had done this several times it didn’t do anything).

Thanks, added this to my weekly report.

1 Like

We can’t find the cause, but these should be fixed now. @thomaseverest do you any observations afflicted by this bug now? I’m not finding any in spot checks.

1 Like

Identify is down to just 65 observations so it looks fixed! I did find one observation that still had this issue though. I didn’t try and fix anything if it helps to have it available.

Did you do anything to fix it?

Not sure how I missed that last one, but I just fixed it. Still stumped on how they ended up that way. Usually I blame taxon changes, but that doesn’t seem to apply here.

1 Like

I just found some more observations that are stuck at non-species-level in Needs ID despite having what should be enough IDs of Rumina decollata to go to Research Grade. Their observation taxa are not Rumina decollata because they had different initial IDs – perhaps this is why they didn’t get fixed with the others? A lot are at Rumina, some Stylommatophora, etc. All were IDed 2+ years ago.

Examples: – observation taxon is Stylommatophora even though there are 3 Rumina decollata IDs; community taxon field and data quality assessment say it does not have 2 IDs – same – observation taxon is Rumina, which was the initial ID, despite 4 subsequent R. decollata IDs – same, with one ID as Rumina followed by six as R. decollata

Also, related but slightly different: – a third ID was added after 2 Rumina decollata IDs and that is the observation taxon; the community taxon does not exist as iNat thinks there are not 2 IDs; the 3rd ID does not show as a disagreement. This one shouldn’t be RG anyway, but iNat should be seeing the R. decollata IDs, not ignoring them.

It’s as if iNat just can’t see the Rumina decollata IDs and is basing its assessment on whatever other IDs there are.

I added a fifth species-level ID to and it switched to Research Grade, so that does still seem to work.

Changing the DQA brought the first two to R. decollata, but they’re not RG. Similar for your last example, and there’s also no community taxon.

I went ahead and IDed the ones I’d found; hopefully if there are more sitting at intermediate taxonomic levels they’ll get found eventually.