Decayed positional accuracy?

I am not sure whether this is a bug or not.
I am mapping records for the BC Conservation Data Centre and have found a discrepancy in the positional accuracy I originally recorded for certain observations and the positional accuracy as currently represented on the iNat observations themselves.

There is more than one instance of this, but here’s an example:

I exported observations of this species last year and found that this observation had a positional accuracy of 43m. Looking at the map, the radius of the circle appears to correspond with that range of positional accuracy. However, if one inspects the observation details, the accuracy is reported at 26.55km!

Whether the user has changed the positional accuracy of this record, or this metadata has somehow decayed since it was originally mapped, or is for some reason being misreported… either way, iNaturalist is misrepresenting the positional accuracy with a circle that is much smaller than the positional accuracy that’s being reported in the observation details.

I am encountering this issue regardless of what platform I use, Mac, PC, Chrome, Safari, and MS Edge.

1 Like

the taxon of this observation is listed as critically imperiled, and although the observation’s coordinates do not currently appear to be obscured, signs are they were probably obscured at some point. when obscuration is applied to an observation, the observation is represented as a random point in a 0.2 deg lat by 0.2 deg long box, and the accuracy is represented as the diagonal of that box.

it’s not clear why even after the observation is no longer obscured its accuracy seems to reflect the obscured accuracy. normally, i would just toggle one of the DQA flags on and off, which could force the observation to be updated, and it’s possible that that could resolve the immediate issue. however, you may want to hold off on trying that to let folks do a little troubleshooting first.

here’s a snippet from the API (, where acc shows as the reported 43m, but public_positional_accuracy is set to 26550m:

{"total_results":1,"page":1,"per_page":30,"results":[{"quality_grade":"research","time_observed_at":"2014-05-20T17:50:00-07:00","taxon_geoprivacy":"open","annotations":[],"uuid":"06ae53a0-676d-40bb-a876-69071cae018c","observed_on_details":{"date":"2014-05-20","day":20,"month":5,"year":2014,"hour":17,"week":21},"id":21814236,"cached_votes_total":0,"identifications_most_agree":true,"created_at_details":{"date":"2019-03-30","day":30,"month":3,"year":2019,"hour":21,"week":13},"species_guess":"Washington Snowshoe Hare","identifications_most_disagree":false,"tags":["2014","BC","Belcarra","canada","iNaturalist","Mammals","Vancouver"],"positional_accuracy":43,"comments_count":0,"site_id":1,"created_time_zone":"America/Los_Angeles","license_code":"cc-by-nc","observed_time_zone":"America/Los_Angeles","quality_metrics":[],"public_positional_accuracy":26550...}


I agree that this definitely looks like a previously obscured observation which would have made the observation have a positional accuracy in the range of 25-30 km. I wanted to see if this affected other observations of the species in Canada (where it looks like obscuration was lifted), so I flipped through the Identify modal to get a quick view of this.
When I look in Identify, however, the correct accuracy of 43m displays?:

If I click on “View” and look at the observation page, it returns the 26.55 value. Not sure what is going on there.

1 Like

I tried this on our test server and it worked, so it looks like a reindexing problem, probably from when this status change happened. Please don’t try it on this observation if you can, though.


There are two issues here. One is that Identify shows the positional_accuracy, while the observation page shows the public_positional accuracy – this has been reported previously.

The second issue is the public_positional_accuracy seems to not have updated automatically when the observation became unobscured. This used to happen, but was fixed a couple years ago. I suspect that the issue with this particular observation is that it was unobscured before the fix was rolled out.


Thanks everyone for your feedback. @tiwane —is there a solution for the issue?

Thanks again!

Are you asking if there’s a solution for it right now, or if there’s a solution that will be implemented right now?

Nothing at the moment. We’d have to decide how to deal with the first issue, which, as @jwidness wrote in her bug report, touches on a few things. For the second issue, perhaps there’s a script that can update those, but I don’t know right now.