Desktop - website - observations won't load

For maybe two weeks now, the website has not worked for me at all. I thought it was a universal issue but it doesn’t seem to be. I can see observations of people I follow on the home screen, but when I click on an observation I just get a spinning loading icon (menu bar is visible at the top though) which eventually brings up an “unknown error” window. For Identify, it will show the search bar, but I’m unable to enter in any locations, and eventually I also get an “unknown error” box. Same thing on my observations page. The only thing that seems to work is Community.


Tried on both Chrome and Firefox, latest versions. Windows desktop

Does this page load for you:
https://api.inaturalist.org/
If not - what message do you get?

It does not. I just a connection timed out message

That’s the server where most of the data is fetched from. Since it seems to be working for other people (me included) the problem is probably on your side. I’m not sure how to troubleshoot that besides the things listed at the error message - checking your network configuration. Maybe you could ask your Internet provider why you can’t access api.inaturalist.org.

Thanks for the help!

open your browser’s developer tools. (it looks like you’re using Chrome. so More Tools > Developer Tools… or Ctrl+Shift+I.) look in the Console section. what error messages do you see?

I just tried it on my iPhone, using both Chrome and Safari and it’s the same. So I think it’s got to be something with the network or ISP itself? It works on my phone if I turn wifi off. On Chrome desktop it shows this in the develop pane:
inat 4

go to the Console section, not Elements. do you see any error messages in the Console?

Ah sorry. Here:
inat 5

do you have problems with any other websites? how fast is your internet connection? are you using any extensions or VPNs?

No, no problems with any other websites. I use an adblocker, which I just turned off for the webpage but there was no change. No VPN. My internet connection is very fast. I don’t have any kind of special firewall settings either, just whatever Windows 10 defaults to.

Did you try clearing your browser cookies? I’m not sure if that would help, but for me it makes sites faster sometimes.

Yes, just deleted cookies. Didn’t fix it.

maybe try restarting your router. if that doesn’t help, it might be best to call your ISP and see if they can help. there are lots of potential issues in the chain. so they can probably rule out a lot of things faster than us trying different things one by one.

3 Likes

Thanks, I’ve contacted them and will see what they say. I also confirmed that the website works when I go through the Remote Desktop that I use for work.

1 Like