Error when adding new places to iNaturalist

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Website

Browser, if a website issue (Firefox, Chrome, etc) : Chrome 104.0.5112.81 (64 bits)

URLs (aka web addresses) of any relevant observations or pages:

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.): When trying to add a new place the website always shows me a message error.

Step 1: Go to

Step 2: Click on Add a new place

Step 3: Complete the survey and submit it.

Step 4: iNat won’t allow you to do it and instead redirect you to a error page.

i had no problem just now creating a small test place (and then deleting it). last night, there was some scheduled maintenance. so i wonder if you tried to do this just while the system went down?

you should try again this morning. if it doesn’t work, please provide the full screenshot of your browser window when you encounter the issue (including the URL / address bar), and also provide the KML file that you’re using to define the place boundaries. (you can either copy the text of the KML file into a forum post, or put the file in a place where it can accessed by others.)


Yes, I was aware about the maintenance hours. I tried it before and after the maintenance, but still doesn’t work.

Here’s the full screenshot of the error page. It marks 500 Internal Error.

I also tried it on Firefox 103.0.2 (64-bit)

Here’s a google Drive link to see the kml archive:

it looks like iNat expects KML files to be Lat + Long only, but your file has an extra Altitude component. if you’re not able to regenerate your file in Lat + Long format, you can open up the existing file in a plain text editor, and do the following:

  • remove the altitude tag that looks like this: <gx:altitudeMode>clampToSeaFloor</gx:altitudeMode>
  • look for the section that defines the boundary of your place polygon, which is defined as a series of coordinates separated by spaces. each of the coordinates will be expressed in Long,Lat,Alt format (ex. -116.969762351801,32.53004399150907,0). you’ll want to effectively get rid of all the altitude values so that you end up with just Long,Lat (ex. -116.969762351801,32.53004399150907). in this case, i think the most reliable way to do this will be to:
    • find all instances of the string ,0 - and replace each instance with a space followed by a negative sign
    • find the last ,0, and delete that.
  • save your file, and use that new/updated file to load your place

just as a side note, it’s probably not great that the place page just fails with a generic message, instead of more gracefully handling this kind of error by giving you a message that indicates that the file was in an unexpected format. i’m not sure that counts as a bug though, and i’m not sure it’s necessarily worth the effort to change the page just to add this kind of validation.

UPDATE: i changed the find/replace advice slightly above from the original version.

1 Like

Thank you so much!! you were right, it was because of the altitude attribute. I initially enabled it because the shadow area on Google Earth looked wonky, never thought it would affect it.

1 Like