Explore on Desktop Loading Extremely Slow

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): Windows 10

App version number, if a mobile app issue (shown under Settings or About):

Browser, if a website issue (Firefox, Chrome, etc) : Firefox

URLs (aka web addresses) of any relevant observations or pages: https://www.inaturalist.org/observations

Screenshots of what you are seeing : Hard to get a screenshot of latency.

Description of problem Right now accessing the “Explore” option from desktop is incredibly slow. Tried restarting my computer, home network, and running an internet speed test which all point to the site being the issue. All other functions of iNat seem fine, it just seems to be having a really hard time pulling up observations in a timely manner.

Step 1: Press Explore on the desktop site

Step 2: Wait for a solid minute just to be able to type or see the map.

1 Like

Having the same latency problem trying to view my own observations. Using Linux/Firefox on a desktop.

I have not had any issues this evening in Chrome on Windows.

Just tried running a search on Chrome and indeed it seems to work on there. I guess this is limited to just Firefox?

open the developer tools in your browser, and look at the network monitor. it should look something like the screenshot below. look to see if you see error messages in the console or anything that’s taking a long time to run in the network monitor.

2 Likes


There’s the issue. Google is attempting to track analytical data through iNat and literally all my apps that stop online tracking, including my own antivirus, are blocking that specific connection. Why is this only an issue now though?

1 Like

i don’t think blocking the analytics stuff should matter. is there anything that’s taking a long time to retrieve data (either completed after a long time or still running)?

1 Like

Here is a more complete list of processes:


It doesn’t seem to be spending a ton of time on anything specific and a second error showed up that wasn’t there the first time I tried this. The map of observations never fully loads and zooming into the map one smidge at a time will cause it to freeze up until it eventually loads. I basically can’t input anything into the search field because it doesn’t produce any drop down fields.

1 Like

if you keep scrolling to the end of the network monitor list, do you see anything that takes more than 2 or 3 seconds to complete, or do you see anything that’s still running, or do you see anything that shows anything other than the green 200 or something similar on the left side?

1 Like

Indeed, yesterday (about 3 PM GMT) I found a severe decrease in performance (and an increase in resource usage) of the observation search in Firefox. In Chrome, the issue is not detected.

Screenshots of performance measurements now (Windows 10):

Firefox (114.0.2)

Chrome (114.0.5735.134)

1 Like

No specific operation takes over 1 second. Closest was 900ms to load a picture of a crab. I’ve tried loading the Explore page multiple times and it seems to spit out different errors every time. Here’s an example of a big group of errors on one occasion:

I am going to reply to this because I use Firefox on a MacBook Pro, the slowness is new for me tonight as well, and I wonder if the changes are related. I have two screenshots attached showing a difference in results on the observations page. This occurs for every search I’ve tried, but for reference, these screenshots are for search https://www.inaturalist.org/observations?verifiable=true&taxon_id=61882&preferred_place_id=1&locale=en. Safari results appear to be the same as Chrome. As has been reported regarding the speed, Chrome appears to respond as expected as does Safari.

FIREFOX:

CHROME:

The “Unknown”, rank, and figure head over observer photo are all new on Firefox tonight. I’ve tried to get Firefox to show in List mode rather than Grid mode, but there is no response.

1 Like

Also having this issue (same environment as OP, Firefox + Win 10 + no-tracking settings).
In addition, my operating system is English, iNat is set to German.

Worked fine until last week. That’s when the bookmark I use to launch iNat (own observations + area limited to my geographical region) started to disregard the restriction to local region; it now simply ‘forgets’ any location restrictions, period, every time, also when searching for a species in an area – it tends to default to country and sometimes even to continent. While the place restriction used to stick around also for any subsequent search, now it does not.

And starting last night I get the slow-down error in addition to this (after loading for several minutes):

  • There is now an extra line at the top of observations (showing the order as ‘unknown’)
  • The Latin species name now has a label (‘species’).
  • The common species name line is now populated by the species name plus the species name+species tag).
  • The size of the box remaining the same, all other info is cut off at the bottom.
  • There is now a portrait icon sitting over the avatar.

These are all internal ‘things/tags/labels’ that are normally invisible but are now being shown.

Edit: After posting this, I got a notification for a Firefox update. Installed, but issues remain unchanged. Incidentally, all other websites continue to load fast and work fine (including this forum).

1 Like

the errors while getting stuff from maps.google.com and probably googleapis.com seem problematic. your earlier screenshot showed maps.googleapis.com getting blocked by an ad blocker.

the Explore page does use Google Maps for mapping and location lookup. so if Google Maps components are getting blocked, then that would explain why map related features would not work, but the issue should manifest less as slowness than as just plain nonfunctionality.

you could try whitelisting the specific domains in your adblocker or disabling the adblocker altogether, and see if that helps.

it may also be worth noting that there was a previous change that should have more gracefully handled situations where maps.google.com was blocked, but i wonder if now it might need to also handle cases when googleapis.com is blocked, too. see https://forum.inaturalist.org/t/taxa-pages-are-blank-if-google-maps-is-blocked/26146/7.

3 Likes

I’m getting the impression from the discussion that this is a Firefox thing. And as of this morning (9:30 EDT) I effectively can’t use iNat at all. I’m concerned that Google has implemented a change that hobbles Firefox under some new set of circumstances, possibly by taking advantage of Firefox protection features. I won’t use Chrome - I try very hard to minimize my use of any Google product, although it’s obviously impossible to do so entirely. I’ll spend some time today trying to turn off adblockers and privacy protections, but it’s not the ideal solution. Any additional advice from people who know more about this than I do will be welcome! :-)

1 Like

If I understood correctly, the issue is some function that is properly executed only by the Chromium web engine. I have tried several browsers:

Pale Moon (Gecko-based like Firefox) - the issue exists
MS Edge (now also Chromium-based) - works correctly
Ungoogled Chromium (Google Chromium, sans dependence on Google web services) - works correctly

So until the issue is fixed in Firefox (I prefer this browser too), the site can probably be used only in Chromium-based software.

2 Likes

I don’t know what happened, who tweaked what, but now everything works fine again with Firefox.

The only thing that is still not working as one week ago is that the place restriction continues not to stick. It requires a separate trip to the filter dialog to re-enable the place search every time.

1 Like

Actually, it’s working in the browser (Firefox) now without CPU or memory overusing.

1 Like

Same here - everything seems to be working fine now.

1 Like

Glad it seems to be working now. FWIW I use Firefox on my MacBook and didn’t encounter this issue at all. I tried turning all my extensions off earlier today and that didn’t seem to make a difference.

1 Like