GPS coordinates do not pull up correctly on map in iOS app v. 3

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website): iOS 14.0.1

App version number, if a mobile app issue (shown under Settings or About): 3.0.2 Build 603

Browser, if a website issue (Firefox, Chrome, etc) : not applicable

URLs (aka web addresses) of any relevant observations or pages: not observation-specific

Screenshots of what you are seeing (instructions for taking a screenshot on computers and mobile devices:

(I am a new user and limited to only one embedded item. I was going to upload 3.)

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):
Observations no longer display the proper location when viewing or editing them on the map in the app on iOS. The GPS coordinates are still stored. They show correctly on the map on the website in a browser. They go to the correct location if I put them in a maps browser (e.g., Google maps) and if I put them in the Apple Maps app. However, they are miles away on the map on the iNat app in iOS. This is new behavior possibly since the 3.0 upgrade version before your latest 3.0.2 update. So I then installed the 3.0.2 update and the problem is still occurring. I then deleted and re-downloaded the app, and it’s still happening. Fortunately, the coordinates remain in the record. “Acc” field has been containing “???” since the 3.0 upgrade (or possibly “??”). If I do a manual adjustment to the location using the map, it may change those question marks to a value. As you can see on this example, it’s showing “20m”. Is that supposed to be 20 miles accuracy when obscured? If so, then it may be showing that to me in the app even though I’m logged in and it should not be showing me the obscured value. You can either use the coordinates as defaulted from the ones embedded in the image detail OR add your own. They still show up incorrectly on the map in the app. Note that I did not try to do this with non-obscured location.

Step 1: Take photo with Location services for camera enabled OR add your own coordinates.

Step 2: Upload and save in app iOS v. 3 or 3.0.2, making location Obscured.

Step 3: View map location in App on map. View same in a browser on iNaturalist website. The former should be incorrect and the latter correct.

1 Like

Additional screenshots.
Incorrect map coordinates from app.

Correct information, from web.

Hello, and welcome!

I see that many, if not all, your observations are obscured. This is likely causing the confusion.
There are several contexts in which you, the poster, can still see the true coordinates, and others in which randomized coordinates caused by the obscuration will display, despite your being the original observer. If I used iOS I’d be happy to show you what an obscured observation looks like there from another user’s perspective.

If that’s not the case, and this is a bug, there are a bunch of known bugs in the latest iOS releases. You can try completely uninstalling and reinstalling the app, it has helped in some situations. All you information is stored on the iNat servers and will not be lost.

Thanks for the report! Hope to keep seeing you on the Forums.

1 Like

Hi. This was working fine until I installed 3.0. By “working,” I mean I could see my own obscured location on the map in the app. I understand how obscured coordinates work for the non-poster. I’m not sure what you mean by “confusion.” I know what they look like from another user’s perspective.

That said, that I’m pretty sure I’m not confused, and that I have already uninstalled and reinstalled the app (this morning, before the screenshots, which I said in my write-up), I think there’s a bug. Can we try this again?

1 Like

Ah, my apologies. I should have read more closely.

I don’t know what else to do, personally. I’m not a developer, only a volunteer moderator. Someone else should come along soon who can be more helpful :sweat_smile:

Thanks! Is this not where we make bug reports? I can send it somewhere else if needed. :)

Not only is it in the correct place, you have done the usually-neglected and much-appreciated task of filling in all the questions. Thank you.
Staff (and some users) monitor the Bug Reports section regularly.

LOL – thank you! :) I hope you have a good day. After going through the steps, I was at least glat to see that the coordinates were not “getting lost.” :)

:) You, too.
nice cat.

You, too! :)

Just to clarify for those reading, it wasn’t until the Steps to repeat the problem in my original post that I said the problem is with your own posting of observations. I guess to reword the problem, it appears that in the iOS app (I can’t test Android because I don’t have Android), it possible that the mapping of your own observations is showing as Obscured. That’s my guess, anyway. Perhaps someone let that slip through in the code. (@trh_blue I am a developer and have no excuse for not describing this better. :) )

Most I ever did was experiment with Java and Python for about five months in high school. Enough to get the gist but I didn’t sustain an interest. Good luck getting this solved quickly

1 Like

If it were open source code, I’d go take a look. ;)

1 Like

I had to say that…


I can replicate, we’ll take a look.

1 Like

A post was split to a new topic: How to follow iNaturalist Github?

Hi! Can I get a status on this? I was looking at change comments that have been made in the past few days (in GitHub), and I can’t tell if it’s been addressed or not, or if it has, whether or not it’s been released. I just installed iOS version 3.0.5 Build 609. Release notes were as usual.

Obscured location coordinates of my own observations are still not showing to me after that install.

Thank you.

The coordinates (lat/lon) show, but they show up incorrectly on the map. Works fine in a browser. So there seems to have been no change. Just checking.