I want to add photos to my observation on the laptop browser but cannot

I use Firefox.
I have no problem creating a new observation but sometimes the photos don’t load. So I:

  1. hit the add photo button but it never works loading a new photo from my desktop
  2. hit the EDIT button but the photo management section is completely in greek and although I have 2 science degrees I cannot figure out how to use it.
    Can someone tell me
    a) is this a common complaint?
    b) how do I add a photo to my observation record using eithe 1 or 2 above?
    Thanks

Button to add a photo is on the right side, under photos, then ther’s a blue save button at the bottom.
What are the parametres of the photo use you want to add? Could it be too large to be processed?

Have you tried the drag and drop method, with your photo folder open at the same time as you create a new record? That’s always worked for me. Have not generally used other methods to get a photo into the record.

This can happen if you upload a file format that isn’t currently supported like .heic, there isn’t really a clear error message it just doesn’t work.

@marina_gorbunova @jnstuart @wildskyflower Thanks for your replies.

The Add Photo button doesn’t work for me. In the Add screen, I use the Browse button, find my photo, hit add, then nothing. There’s something about syncing with metadata but I don’t even know what that does and it doesn’t explain it.It just sits there. I’ve tried saving it at that point but it never adds the photo.
Drag and drop works fine for new observations. I’m trying to edit an existing record.
I add these same photo formats to my new records without problems.

I will avoid adding photos this way. It works great on my android phone. For the record, I find this entire enterprise very user-unfriendly. Everything has a learning curve and I’m getting tired of always climbing them every time I get an idea of doing something. I’m using Firefox. Thanks for you help.

Sorry, can’t help with Firefox, I just checked on Chrome and even though spinning circle takes quite some time, it saves after maybe 10 seconds. Drag and drop is working on existing observations too for me, you need to drop it on that grey icon. It can be a file problem or browser problem.

1 Like