Images not displaying, uploaded images appear initially then break, observations don't load

Platform: Australian Website

Browser: Firefox 81.0

Observation e.g.


Description of problem:

As per screenshots (has been working fine until today)

Step 1: Images not displaying on home dashboard

Step 2: Uploaded images appear initially then disappear?break (no screenshot due to new user limitations)

Step 3: Individual observations don’t load (spinning wheel) (no screenshot due to new user limitations)

Hm, that observation is displayed correctly for me.

Welcome to the Forum, @quiet1_au :)

Works for me too

I had some strange slow loading times today on the main iNat website, like 25 seconds to open my Lists page. I wonder if it was an intermittent connection issue?

I updated your user status so you should be able to add more screenshots if you need to (@tiwane I wonder if you can raise the limit?).

OK - it appears to be an issue with the iNaturalistAU node (part of Atlas of Living Australia) - the main site does appear to be working fine. I will try to contact them directly about this issue.

I’m taking part in the Great Southern Bioblitz and the instructions said to use the local node - probably to spread the load on the servers? If I have to use the main iNaturalist site hopefully it will still tally my observations (I’ll upload one as a test)

I had also logged into the Australia portal earlier and now and didn’t have any issues, which is why I thought it must be something local or intermittent. It’s still not working for you?

1 Like

Hmm - I just tried logging in with Internet Explorer and the images are working as you say. Uploading new images also worked with IE (although slow to suggest IDs)

Sorry, it looks like it may be a browser/cache issue on my system not the site after all…


No worries! If it happens again, pressing F12 and seeing if there are any messages in the developer console can sometimes be helpful for troubleshooting.

1 Like

I remembered I have AdBlockPlus and PrivacyBadger installed - although these haven’t caused any problems previously it appears that Privacy Badger was the cause of today’s issues as as soon as I disabled it the images loaded…

Thanks everyone for your assistance