IOS app crashing and laggy

Please fill out the following sections to the best of your ability, it will help us investigate bugs if we have this information at the outset. Screenshots are especially helpful, so please provide those if you can.

Platform (Android, iOS, Website):
App version number, if a mobile app issue (shown under Settings or About):

Description of problem (please provide a set of steps we can use to replicate the issue, and make as many as you need.):
My Inat app has been consistently crashing the past few days despite having a strong Wi-Fi connection, lots of free storage, and other apps are working as normal. Today the app was “skimming” observations to upload, partially uploading an observation but skipping over it, and only a few were uploaded. I also was kicked out of the app multiple times while uploading.
Has this happened to others recently, specifically today? And is there a way I can fix it?

When did the crashes start? What iOS version are you on?

I’ve never seen this “skimming” behavior you describe. Are there errors on the observation after it fails to upload? Is your network stable? Can you make a video of what it looks like?

When you say kicked out, do you mean that you were logged out? If you were logged out, what was the error message when you saw the login screen? A screenshot would be helpful here. If you were not logged out, what do you mean?


1 Like

By kicked out I mean the app shut off and returned me to the home screen. My IOS is fully up to date.
And the “skimming” is when the green bar goes halfway to almost full but then goes to the not uploaded observation above it, and repeats that cycle leaving all the observations I tried to upload not uploaded.
It’s confusing but I hope this clarifies. I don’t know if I could upload a screen-recorded video to the forum, is that possible?

You’re not running the iOS 17 beta? Just checking.

It’s a lot easier to associate crash reports from Apple with user complaints when I know the specifics of a user device so I can sift through Apple’s crash reporting tools and try to figure out which one might be happening on your device.

I’ve never seen that. I just tried a batch upload with the latest release and it worked fine for me. Are there errors that show up on the observation? If you open observation details for one that fails to upload, are there any error notices at the top of the screen? Does this happen every time you try to do an upload session? And is the internet otherwise working fine on your phone?

You can email to

my email address

if you would prefer.

Just started a few days ago. Perhaps tomorrow it will be back to normal.

We’re a few days into a phased rollout of release 3.2.13 on iNat iOS. Today, 10% of users have it, but tomorrow it will be all 100%.

So I am hoping that if there is a bug causing slowdowns, I might be able to find and fix it before it became too widespread.

1 Like