Latin names hidden in app (but not in computer version)

Hello! I set my preference on the computer version of iNaturalist to display Latin names preferentially, but the app on my phone still shows “common” names by default. How do I get the app to show my Latin names by default? I’ve tried closing the app and reopening it, and even rebooting my phone, but it still doesn’t take my preference into account.

Are you using the iOS or Android app? The iOS app does not support latin name preferences as of yet.

Sorry, I should have specified that I’m using iOS.
Stupid Malus domesticus and its relatively closed operating system. . .